Home Store Blog

18.10 - Adding second user - fails to start session


#1

Have one laptop that has had UB 18.10 installed for several weeks. Can create a second user successfully and log in OK. Installed UB 18.10 with an ISO about 1 week old. Install went correctly. Tried to add second user and it was created OK. However, when I try to log in get message “can’s start session”.


#2

login as that user via a TTY.

run:

journalctl -ae --full

Use the scroll keys to move around - see if you can find out what the issue is via the systemd log file you are viewing.


#3

When I created the second user I created the password for the user and this had a problem logging in. So, I deleted the second user and then recreated it. This time I checked the box to set the user create their own pw on first login. This time everything worked correctly.


#4

interesting.

Can you repeat this with a third user with a specific password for the user?

If so please report that on launchpad - that snippet of info would be useful

ubuntu-bug gnome-control-center

or possibly

ubuntu-bug lightdm

Looking in journalctl and seeing why the failure to login will give an indication where the problem is and where it should be reported.


#5

I am afraid I did something stupid since I can’t reproduce the problem regardless of how many users I add. Can you delete this thread?


#6