Budgie Setup & Welcome bugs

If during Setup I select Dutch language instead of English, after installation Budgie Welcome loads, but I cannot get that screen to show to update Budgie and install Extras. The button doesn’t do anything.

Switch to English and it works.

Before Installation you are asked whether you want to install Extras/3rd party stuff. If you select that… nothing extras is actually installed. You still need to go to Budgie Welcome and Install it yourself. I believe this is the case since I started using Budgie, 19.04 and the issue still persist in 20.04.

What warnings or errors do you see if you run and do stuff via

budgie-welcome -d

Note extras/3rd party stuff refers to drivers and other restricted software … it has no relationship with budgie-extras and the backports ppa

$ budgie-welcome -d
[Debug] Running in debugging mode. 
[Welcome] Using /snap/ubuntu-budgie-welcome/212/usr/share/budgie-welcome/ path. 
[Welcome] Using /snap/ubuntu-budgie-welcome/212/usr/share/budgie-welcome/ path. 
[i18n] Locale Not Available: null (using en_US instead) 
[Welcome] Using /snap/ubuntu-budgie-welcome/212/usr/share/budgie-welcome/ path. 
[i18n] Locale Not Available: null (using en_US instead) 
[i18n] All translated i18n pages found. 
[i18n] res_dir:  
[i18n] Using locale for gettext: null 
[i18n] Using path for gettext: /usr/share/locale/ 
[i18n] Translation found for gettext. 
[Network Test] Establishing a connection test to "http://archive.ubuntu.com/" 
[Specs] Detecting graphics vendor...  
[Welcome] Using /snap/ubuntu-budgie-welcome/212/usr/share/budgie-welcome/ path. 
[i18n] Locale Not Available: null (using en_US instead) 
[Welcome] Successfully pinged: http://archive.ubuntu.com/ 
[Specs] Detected: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev c2)

I ran the command after opening Budgie Welkom (Dutch version) and after clicking Updates & Extras and then Stuurprogramma’s (=Drivers).

After running the command, the US English version popped up.

ok - having look at this a bit further, the issue is that the code is having problems dealing with the apostrophe in “Updates & Extra’s” and “Stuurprogramma’s”

If the apostrophe wasn’t there - all would be well.

hmm - need someone with more advanced javascript knowledge here to help!

EDIT: ok solved. Just waiting for the daily build before promoting the snap to stable

1 Like

Ahah! I love that translation! It’s really funny… “Aan de slag”… Litterally “Let’s get to work” instead of “Getting Started” (“Au boulot!” for @Coeur-Noir). So typical of Dutch speakers. Made my day.

This is now fixed and released.

The snap will autorefresh sometime over the next week - or you can force a refresh via

snap refresh