Home Store Blog

Change default Print shortcut

#1

I’m having a heck of a time trying to create a new shortcut for a different screenshot tool (Flameshot). I’m trying to create a custom shortcut that uses the Print key, but when I click on that button to set it, it’s actually executing a screenshot and not setting the key to the new custom shortcut. I’m assuming it’s using the default gnome Print shortcut. Is there a way to disable it so that I can set the Print key to a custom shortcut?

Here is my current keyboard shortcut settings for any ‘screenshot’ shortcuts:

Doug

#2

With v10.5 upstream hard-coded the various print keyboard shortcuts to use gnome-screenshot. So I am afraid there isn’t any method other than to change the code.

Yeah… it’s a pain. I am afraid you are going to have to use an alternative keyboard shortcut …

#3

Wow. One of the benefits of linux is the ability to customize things. Limiting something as trivial as a shortcut seems ridiculous. Certainly not the end of the world, but that decision doesn’t make any sense.

#4

Ah well. Not my decision here. I suppose a code change to make it more flexible would be possible. But I do know upstream have no plans to resolve this themselves until v11.

1 Like
#5

No worries @fossfreedom, not that big of a deal. Thanks for looking into it for me.