Darktable has now maximize button

Hi. I’m on budgie 20.04 and i am working with darktable. In budgie it has now maximize button.
I tried to install gnome-tweak-tool and there it is all setted up like it should. also other windows have all three buttons.

Somebody can help me out?

If this is the only app doing this, then logically it’s a bug with the app. Suggest report it to the dark table github project.

Maybe try to change ( widgets ) theme in your Budgie Desktop Settings ?
Default is pocillo.

But yes there should be a « maximize » button in Darktable’s title-bar.

I contacted darktable team. It has to do qith the screen resolution. Darktable is not made for low resolutiin screens thats why there are issues with windows. (also in kde btw) my resolution was 1377x (dont remember other value)
The maximum value which was possible to set on my laptop (also kde)
I found a video how to manually add othe screen settings and i added 1920x1080 60.00 and it worked. Darktable appeared like it has to.
So i’m wondering why there is a limited screen resolution on my ubuntu installation?

Sounds like a bug in your graphics driver.

Please report it to launchpad

ubuntu-bug xorg

Any nvidia graphic card involved ? Or very recent amd gpu ?

If nvidia, are the matching drivers installed ?

i tried to report but it’s too complicated. Cant understand how to report LOL. Anyway if somebody needs more input i can help.


No. it’s no Nvidia card

lspci | grep VGA

0:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

it goes to to maximum 1377x766


setting in .profile

xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsyncxrandr --addmode eDP-1 1920x1080_60.00




strange that it is not out of the box