"Failed to find memory space for buffer" graphics issue

I am sorry if this is the wrong place to ask - if so, could you please guide me to the right direction!

I am new to Linux, and pc building, and just built my first pc and went with Ubuntu Budgie as my OS.

Tried playing Cities Skylines via Steam, everything was dandy until the city was finished loading - then all I got was a pixel mush and found an error message in the system log that said “failed to find memory space for buffer”.

Now, I suspected that gaming wouldn’t necessarily be the smoothest with my chosen budget APU but I did expect games to run nonetheless.

I have:
AMD RYZEN 3 2200g with Radeon Vega 8 graphics

AsRock Fatal1ty B450 gaming ITX/ac

2 x 8GB Corsail Vengeance LPX, DDR4 3000MHz

Again, sorry if I am seeking help in the wrong place, I am so new at this, don’t even know where to start. I appreciate all the help I can get!

Have you run a full memtest?


I tried. I can’t get to grub menu by holding down shift. Do I need to make changes to grub settings?

If shift or escape key will display grub … you have to be quick … its immediately after your bios/efi splash screen that you have to press either key.

I feel like I tried both every which way. But maybe I just haven’t got the techique down. Will try again if I can get it to work.

Ok! Finally managed to press shift at the correct time and ran a full memory test. Zero errors found.

The system then froze when I turned it on and opened Firefox. It has crashed a couple of times before as well (everything freezes except the cursor, and I have to force restart).

So something’s definitely up. :thinking:

Any hints towards what I could do to find out what’s wrong are very much appreciated!

What type of graphics have you got.

Some graphics cards use standard ram rather than onboard graphics ram. You have to fiddle with your bios to ensure memory allocations are specified correctly.

If you have an nvidia based card are you using the recommended nvidia drivers as specified in hardware drivers?

I don’t have a dedicated GPU, I have AMD RYZEN 3 2200g with Radeon Vega 8 graphics.
I haven’t installed any proprietary drivers.
I installed mesa 19.0.8 though.

That’s a relatively old mesa version. Ryzen usually requires the latest mesa and latest kernel … I would recommend you try 19.10. The 19.10 hardware enablement stack will come to 18.04 in feb/March next year.

Ok I see. I installed it mainly because it was easily available via PPA repository (and I thought it would be new enough) and with my very limited (non-existent) skills I naturally gravitated towards that option.
But to summarise: do you think the issues I am having are driver-related?

And would you recommend I go with the proprietary drivers or mesa?