Home Store Blog

Maltego CE on Ubuntu Budgie - Opening File From Launcher Only Launches New Application Window

#1

Hi, scratching my head with this one. For my work I regularly use Maltego CE by Paterva, which is a java application and has worked fine on Fedora 29 and Kali Linux.

I am testing Maltego CE with Oracle JRE 1.8 on Ubuntu Budgie (tried with OpenJDK as well without success), and experiencing a critical workflow issue. I cannot seem to open a specific .mtgl file from Nautilus or the command line. Whenever launched in this way, it only opens the welcome screen for Maltego, rather than continuing to execute on opening the file. So I’m having to open all files within the application file -> open menu, which is not ideal.

My java -version:

java version "1.8.0_212"
Java(TM) SE Runtime Environment (build 1.8.0_212-b10)
Java HotSpot(TM) 64-Bit Server VM (build 25.212-b10, mixed mode)

Tried passing %U and %F options into Exec= attribute below as well for /usr/share/applications/maltego.desktop

[Desktop Entry]
Version=4.2.3.12223
Type=Application
Name=Maltego
GenericName=Maltego
Comment=Visualise, Map and Mine Data
Exec=/usr/bin/maltego
Icon=maltego

Terminal=false

Actions=ConfigureMemory;

[Desktop Action ConfigureMemory]
Name=Configure Memory
Exec=/usr/bin/maltego_memory_config

[Desktop Action ShowWebsite]
Name=Paterva Website
Exec=x-www-browser https://www.paterva.com

Not sure if this is a Ubuntu general distro issue, or Ubuntu Budgie specific. But would appreciate any pointers on any other tweaks I should try.