Nvidia Trying to create xrandr mode fails X Error of failed request: BadMatch

I’m having a hell of a time trying to get my ASUS 27" AUS VG27VQ screen to use 2560x1440 on a notebook:

TUXEDO Book XA15 - Gen 10
Full-HD (1920 x 1080) IPS-Panel 144Hz non-glare
NVIDIA GeForce RTX 2070 Refresh 8GB
AMD Ryzen 7 3700X (8x 3.6-4.4GHz Octa-Core, 16 Threads, 36 MB Cache, 65W TDP)

I have seen a similar question asked here 3 years ago with NO answers but I try anyway.

I follow the procedure as I have read them online:

$ xrandr

 DP-0 disconnected (normal left inverted right x axis y axis)
 DP-1 disconnected (normal left inverted right x axis y axis)
 HDMI-0 disconnected (normal left inverted right x axis y axis)
 DP-2 connected (normal left inverted right x axis y axis)
    1920x1080    144.01 +  72.01  
 DP-3 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
    1920x1080    119.98*+ 165.01   144.00    99.93    84.90    60.00    59.94    50.00  
    1680x1050     59.95  
 ...
 ...

$ cvt 2560 1440 120
# 2560x1440 119.95 Hz (CVT) hsync: 185.33 kHz; pclk: 661.25 MHz
Modeline “2560x1440_120.00” 661.25 2560 2784 3064 3568 1440 1443 1448 1545 -hsync +vsync

$ xrandr --newmode “2560x1440_120.00” 661.25 2560 2784 3064 3568 1440 1443 1448 1545 -hsync +vsync
$ xrandr …

2560x1440_120.00 (0x34f) 661.250MHz -HSync +VSync
h: width 2560 start 2784 end 3064 total 3568 skew 0 clock 185.33KHz
v: height 1440 start 1443 end 1448 total 1545 clock 119.95Hz
But when I try to add mode I get the error:

xrandr --addmode DP-3 2560x1440_120.00
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 18 (RRAddOutputMode)
Serial number of failed request: 39
Current serial number in output stream: 40

I have tried on both HDMI and Display Port with the same result.

I placed a call to Tuxedo but have not received a working solution.

The same screen WORKS in 2560x1440 using similar instructions with another computer using same version of Ubuntu Budgie.

NOTE: I can use nvidea-settings to select this mode 2560x1440 and it works fine for a while but then reverts back to 1920 automatically ?

I’ve tried creating xorg.conf and modifying .config/monitor.xml wihtout any success.

Anyone have a idea ?

Did you try the ideas here?

You didn’t mention what version of ubuntu budgie you are using nor what version of the nvidia driver.

What versions of nvidia are you offered in hardware drivers? Does switching to any of them help?

I have tried all of the suggestions I found online, that is why I’m posting here, I have also had Tuxedo support who can offer no help, however, as my NUC computer displays 2540x1440 perfectly using the same OS and same Budgie version, I’m persisting as I cannot work on 1920x on a big screen and 4K, even in fractional scaling does not work due to the horrible flickers and screen switching on and off.
The link you propose is one of the ones I saved.
I have no idea what you mean about versions of nvidia drivers as I have not touched anything in that area, I’m happy to try other settings and versions but wouldn’t have a clue about going about this … I don’t like screwing around with drivers and low level stuff that sometimes ends up bricking my systems.
The Version of Budgie is
Version 0.16.0
Budgie Desktop 10.5.1-6ubunto0.2 (Ubuntu Budgie 20.04 focal)
Thanks in advance.
P.S. The way I do it now is I just have a one line script which I run whenever it reverts.
nvidia-settings -a CurrentMetaMode=“DPY-4: nvidia-auto-select @2660x1440 +0+0 {ViewPortIn=2660x1440, ViewPortOut=1920x1080+0+0}”
What pisses me off, is that I cannot save it, it works fine but it reverts back all the time

Does it revert randomly or on re- login?

Randomly ! Perhaps tied to when the screen blanks, I work on two similar size screens on two different computers so I’m not always on this one… And of course after the screen wakes up when I arrive in the morning