Pixel Saver Applet not hiding Window Bars

I really loved the applet and miss it. Do I need to reinstall the Pixel-Saver-Applet at some point from Budgie Welcome, or is it sufficient to run the usual update process (apt update, apt upgrade) to see an eventual fix?

Assuming that a fix is available, we will release an update to the package - so it would just be a normal update/upgrade.

ok - found some time to look at this and added a patch to the disco package.

Please update and test this out for me. Let me know how you get on.


Using the applet right now. Everything looks in place. Windows’ headerbars are hidden when the windows are maximized. Buttons are also working as expected. Congrats. Anything unusual I’ll be back in touch.

Using the Pixel-Saver-Applet, I noticed that hiding the headerbars does not kick in when the app is first opened. The app needs to be minimized and maximized again, or closed and reopened. This needs to be done with any application: Opening, for example, Mailspring, does not solve hiding the headerbars for any app that I open subsequently. Any app needs to be opened, closed/ minimized, and reopened/ maximized for the Pixel-Saver-Applet to hide the headerbars properly. The effect is not particularly annoying, it just called my attention.

Apps that open maximised ?

Here are a few screenshots to illustrate:

First picture is when I open the application (here: Eclipse) for the first time. The app window is fully maximized. Header-bar is still not merged with the top panel. Header-bar, Minimize-and Maximize buttons are all visible. I would expect the buttons to be already hidden, as should be the header-bar.

Second picture is when I UN-Maximize the application. (All cool here).

Third picture is when I maximize the app window again. Now you can see that the header-bar, the minimize and maximize buttons are hidden and merged with the top of the screen, where the top-bar is. From my point of view, I shouldn’t have to go through the process of un-maximizing and re-maximizing the app window so that that the header-bar merges with the top-bar. It should happen on program-launch.

Kindly don’t get me wrong: This is not a feature request. I understood from your prior post that you would be interested in a test and a feedback. I am just communicating an observation of a - tiny - flaw with the hope to be useful in some way. I am sure you are in a better position than I to decide if any rework is needed or justified.

1 Like

okey - I’ve rejigged the patch. Should fix apps that open maximised now.

Please update as normal.


Just made the update. Working beautifully now. Congrats …

This seems broken again in 19.10 applet is installed i’ve even restarted the pc with no luck on removing the window header bar.

Where did you install the applet from? “Budgie Applets” screen?

Which app are you having issues with? Note - any app that is a client side decorated app (CSD) will not be touched by the applet.

Yes I installed it through the budgie applet app

All windows, an incomplete list for instance: firefox, vscode, libreoffice, archive manager, calender etc.

If you can give me some advice on how to debug it, I will look into it. This is a fresh install so it could be that I am just missing a package.

Can I ask an obvious question - have you added the applet to your panel?

I swear I tried but it wasn’t in the list even after the reboot. I’ve now removed and installed again and this time it shows up in the panel applet list. thank you

What’s the state of this?

I tried the applet from github but it seems outdated and the package from ubuntubudgie-backports (v 4.0+git20200313) does not seem to work either. At least it doesn’t appear in the applet list to be added.

This is my main concern with budgie right now. I’d really like my top bar to mimic the Unite extension in Gnome. I don’t care so much about the global menu but top panel + top bar is one too many on a laptop screen especially.

Do remember to logout and login after installing the package otherwise it will not appear on the list of applets to be added.

…and then add applet to a panel by using « Ubuntu Budgie Desktop Settings ».

( a bit strange to have to logout / login each time a new applet is installed. Can it be automatically reset ? )

Sorry, I guess both versions were interfering. I removed every budgie-pixel-saver related files and folders, apt removed the package, and apt reinstalled it.

It works, but 2 complaints:

  • on dual monitor setup, the top bar on the screen with no top panel is also going into the top panel on the other screen, which is weird and it is hard to unmaximize on secondary screen
  • the controls seem to come as expected on the top panel, but the top bar seem to hide behind the top panel instead of disappearing, the problem with that is you can’t grab the top panel and drag and drop from there to unmaximize. With firefox it becomes complicated to unmaximize in between icons of the menubar or the tabbar (full)

Someone will need to investigate that via the budgie desktop code

Ah. I look at this as opportunities for people with multi monitor setups to resolve!