Public Free DNS configuration problem

Good Morning,
I’m trying to configure a permanent external DNS for my Laptop winth Ubuntu Budgie 20.04 and it keeps rolling back to the local host after every service NetworkManager restart.
I tried configure this in the network settings GUI, but with no effect. I confirmed de configuration in the /etc/NetworkManager/system-connections/‘connection name’ and everything is apparently OK:

when I do a nslookup I get this:

nslookup “domainname”

Non-authoritative answer:
Name: “domain”
Address: 2a00:1450:4003:801::2004

The only way to get pass this is adding the server in the resolv.conf file, but in every reboot or service restart I end up in the original problem.

Can anyone help me?
Is this a bug in the system?

Kind Regards,
Rui Barrocas

Guessing here since it’s not an area I play in

Ubuntu uses a netplan Yaml file for networking stuff … so probably have to specify your dns changes in that

Thanks for the reply.
Tried, but the problem staid the same.
Regards to see which dns is actually used.

What I set into Network GUI is matching ( is a generic for cloudflare dns )

Beware of commas and automatic switchs ?

Thanks for the reply.
I started there.

DNS = so it’s google, seems legit ?

You can there write down many DNS, simple comma separated [ , not ; ] even if am not sure how it’s handled : in theory in case first DNS does not work, system should switch to next in list.