Software updater settings button not responding

Hello,
I want to remove / untick a repository from the software updater. But I am unable to access the settings option.
When I click “settings” button, it does not respond.
From terminal, I get the below error when trying to do sudo apt update

E: The repository ‘https://deb.etcher.io stable Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.

I removed the balena etcher software and now trying to remove the repository causing this error. But not able to as I am unable to access the settings in software updater.
Appreciate your help in this and thank you for your time and support

sudo nano /etc/apt/sources.list

The above will open a text editor with the list of sources.

Add a # character as the first character of the line containing the offending etcher source.

Save and exit then run an update again

Thank you so much for your prompt response. Much appreciated!! that sorted the issue and the update command is working fine now.
But just to note, the software updater is still not responding when I click “settings”. Not much of an issue now, just thought to highlight it.
I have also downloaded stacer in case I face such issues in future so that I can delete the unwanted packages using that
Thank you again

Run

update-manager

From a terminal. Click the settings button. Any warnings or errors displayed in the terminal?