[solved] Unable to connect/unrecognized USB seagate 2TB expansion drive

This is one for the tips department.
I was using external drive for USB backups when it stopped functioning. Restart made the PC hang it could not release the USB even Ctrl-Alt-Del force did not work. Eventually pressed power button (laptop).
From then on I could not access the USB Seagate. Only thing would show was #lsusb . Fdisk would not show, another computer would not show, Disks would not show nor Gparted. Tried putting drive in freezer for 15 mins and restart; zilch. Basically, I was up SC without a paddle.
With USB drive plugged in boot back to Ubuntu/Budgie appeared to hang, but later
some logic told me shutdown method had killed it, so how about startup with drive plugged in and wait for all processes to work.
That was the fix; the kernel had to work through the processes of finding drive and whatever other bits and bobs then brought it back.
Unbelievable, but worked!
Thanks Ubuntu Budgie for your worksmanship.
PS no more Seagates for me this drive has been rubbish and its fairly new.

1 Like