Testing 19.10 - only for the most adventurous

Ok, it’s an upstream enhancement “in progress”.


Testing the above experimental options for fractal scaling in 19.10 mentioned by fossfreedom for the last hour or so, and haven’t yet encountered any performance problems or issues.

1 Like

okay, today’s update (July 9th 2019) broke my wifi. Luckily I have an ethernet connection :slight_smile:

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install firmware-b43-installer b43-fwcutter

did the trick and the wifi is back online, but I was panicky for a moment. Linux kernel update to: 5.0.0-20-generic

I downloaded the 19.10 iso on 10 July and used it to install my my dual boot Thinkpad laptop. The installation went as expected and 19.10 appears to be very stable. However, this morning I tried launch windows 7 from the grub menu and I get the error “The boot selection failed because a required device is inaccessible.” This machine has a SSD.

Done lots of dual boot machines and this is the first time I have seen this. I can fix this but wanted to give a heads up that the 19.10 installer may have a problem. And yes, I did update-grub on 19.10 and it did see Windows 7 partition.

please can you report this to launchpad to make the Canonical aware - do it from the 19.10 ISO live-session please:

ubuntu-bug ubiquity

FYI : I had the McMojave-circle 3rd party icon set cause the entire UI to crash back to the login screen. Plank and the menu were unusable so, I opened the dconf-editor from the terminal and reset the icons to default before removing the icon set.

I can’t be 100% sure it was the installer. There was a big win7 update the last time I used that OS so don’t know if it was an update or the install. I was not able to resurrect win7 with the normal measurers so had to reinstall. After that I also reinstalled UB 19.10 and this time there was no problem with the dual boot.

Today I have uploaded a patch build to budgie-desktop with the following resolved issues:

  1. Desktop tab in budgie-desktop-settings makes a reappearance. So if you use Nemo run

    gsettings set com.solus-project.budgie-panel desktop-icons-handler 'NEMO'

If you use desktopfolder

   gsettings set com.solus-project.budgie-panel desktop-icons-handler 'DESKTOPFOLDER'
  1. Menu’s should now be sorted taking into account special characters such as accents, umlauts etc etc. Previously menu entries appeared at the bottom of any menu list

  2. In budgie-desktop-settings - Fonts - you can now control font hinting

  3. Applications that need “pkexec” to launch failed to run from a menu option - e.g. bleachbit (root) - this should now be fixed

Use fhe test eoan repo:

sudo add-apt-repository ppa:ubuntubudgie-dev/eoan-test
sudo apt upgrade

The very latest development mutter has been uploaded (21st July) - this needs careful testing

sudo add-apt-repository ppa:ubuntubudgie-dev/eoan-test
sudo apt upgrade

New development: QuickChar makes an appearance. So if you write text with special characters such as accents etc it can be difficult to remember all the keycombinations to write those characters.

Enter QuickChar. Press Super+Alt+C and a little dialog appears - type the ascii character the resembles your character and associated special characters appear - click and the character will be pasted into your libreoffice document (for example)

To test use the eoan-test repo and install the package budgie-quickchar - logout and login afterwards

New development: Brightness Controller applet makes an appearance

Use the eoan-test PPA and install the package budgie-brightness-controller-applet

New development: budgie-fuzzyclock-applet makes an appearance


Please use this topic for feedback on this applet.

You can install this via our eoan-test PPA and install the package budgie-fuzzyclock-applet

New development: workspace-stopwatch-applet makes an appearance

So if you spread your work out between workspaces (e.g. different client facing work) and you need to know how much time you spend on any workspace, this applet is just your ticker

You can install this via our eoan-test PPA and install the package budgie-workspace-stopwatch-applet

Both of my Budgie test builds kick back to the login screen after updates. These computers have totally different hardware and one was given a clean installation with the latest daily build 8/19/19. The new installation worked until reboot. I plan to update from the root shell in a day or two to see if that helps.

don’t use the eoan-test PPA for a while - that has the latest mutter that needs an update to budgie-desktop.

All packages have been uploaded to the main Canonical repositories so no need for the test PPA.

I can’t repair this from the root shell, so I will reinstall W/O the PPA which appears to be the cause of the problem.

hmm - surprised - should be able to boot from grub - advanced to the root shell - enable networking and then ppa-purge the ppa.

Could you please post the complete purge command , so I can see if I got it correct?

Thanks !

The purge should be:

sudo ppa-purge ppa:ubuntubudgie-dev/eoan-test

Thanks for the command , I couldn’t enable networking to install the ppa purge, so I reinstalled and I won’t be installing any third party options from Budgie welcome for now.