Ubuntu Budgie on Imac 2017 No Sound

Hello

Yes everything is fine in OS X or even Windows 10 when I installed that on the same drive ( but I soon uninstalled it, Windows is so ugly ) , internal speakers and the jack when I use ear phones.
I have no problem with the output

The sound problem is the same whether I install Ubuntu 20.04,UbuntuDDE,Deepinos ( no sound and no wifi)Kubuntu 20.04 and now Ubuntu Budgie.

I have really gone through all the tips and tricks in the internet.

I’ve purged and reinstalled pulse audio/alsamixer. Changed the output from analog input to all the ones possible. I’ve even tired adding the HDMI from my ATI card.

I’ve added all the ```
options snd-hda-intel model=imac27

I even disabled the ati card with pactl set-card-profile 0 off that I already did in the panel 

Nothing works

Thats why I was hoping to get a developer to help me out

On my old 2010 MacBook everything is just perfect out of the box. 

Anyways I'm sick of trying and rebooting its driving me crazy

I'll stick to the bluetooth headphone method

Cheers

I have done that in my MacBook and yes it’s really beautiful. I particularly like the eye candy that you can add to the windows and styles,

I’m starting to think it might come from the kernel, if someone could explain to me how I can downgrade the kernel to check

This iMac is the 2017 mid June 27’’ 5K i7 4.2 without the T2 security chip

The sliders are all moving showing that te sound is going through but the volume icon is crossed out

Alain, you might try booting w Solus OS. All the other OS you mention are all desktop derivatives of Ubuntu in one manner or another. Solus is built from the ground up, but shares a desktop environment with Ubuntu Budgie. Maybe it would have different audio solutions?

https://getsol.us/home/

A reason for sticking with an Ubuntu derivative would be the larger repository of program choices, and your familiarity with apt vs eopkg.

If you are thinking it’s a kernel issue, you could try booting with 18.04:

http://cdimage.ubuntu.com/ubuntu-budgie/releases/18.04/release/

Before you do (it does sound like you have exhausted a lot of options) check with David: how is the kernel different in 18.04.4? I know for a fact the kernel is older in elementary OS 5.1.4 than in the new Ubuntu Budgie 20.04.

18.04 has kernel 5.3 whereas 20.04 has kernel 5.4

If you think it’s a kernel issue then you can try the very latest kernel 5.6 or later

David FF, I always think newest is bestest :stuck_out_tongue:

Alain, do you still have that macbook? How is the audio hardware configuration different? What kernel is installed on the macbook?

Sorry, I just went back and reread your first post: Can you boot Ubuntu Budgie from a USB directly on the iMac, and test the audio from the USB boot drive? Don’t install the OS, just test the audio. I wonder if asking the external drive to activate speakers thru a USB connection is causing an issue.

You could put an .mp3 on a second drive, put the mp3 on the trial desktop and play it with rhythmbox

Alain, I just went and redownloaded the UB20.04 .iso, burnt a copy w Etcher to a USB and booted. Because maybe this current build is missing something?
Well, the audio test worked the way I expected it to on my macbook pro. The audio test speakers, the cheese camera all sounded good.
(Crappy camera resolution, but I think other people are solving that?)
I really think it’s a case of:
1> a dodgey USB external drive connection
2> something is tricking the speakers into thinking you have headphones in the audio jack.

Jason

The MacBook in a unibody 2010 with intel audio drivers
I had no problem installing Ubuntu or Kubuntu ( which I prefer ) on it
Only thing was that the NVIDIA 350M driver was not used, Ubuntu used the nouveaux xorg driver which works very well but I couldn’t get Blender 3d to accept it and run the latest blender 2.8
I updated quite easily via the additional drivers menu but every time I ended up with a black screen on start up.
Spent about a week and many reinstalls before finding one kind person that made me change a few lines in one or two files and all worked again, I also needed to hunt the internet to get my brightness keys to work and now all is fuctioning correctly.

Only problem is that the Nvidia card isn’t such a good card to run blender correctly so that’s the reason I’m truing on my iMac high end,

For the sound I’ve given up and am now using the Bluetooth headphones,

I now must get blender to accept the ATI card as an OpenGL card to use eevee correctly
The keyboard doesn’t use the function keys too

Another headache in perspective,

Linux is great but really not very user friendly as soon as you want to do something different,

Thanks, ill try it out

I also have had issues with Apple’s Nvidia cards, I think Apple blacklisted them because Nvidia was giving Apple the b-grade cards.
Did you try booting from USB, not using the external USB drive?

Hi

I have installed the 5.68.0 so unless there’s a new one
or if I downgrade to 5,3

I use unibootin to create a bootable usb with the linux .iso, You can also use Balenaetcher or Mac Linux Usb Loader
I partitioned my ssd external into 3 partitions, 1 800 G with macos journaled + and 1 partition with 100 g in EXFAT, the last one in a little 1 g partition to use as EFI EXFAT

Boot from usb using the ALT key. In ubuntu install the distro. use manual install
use EFI partition as EFI Boot
use the fat32 partition as EXT4 formatted and / as root
Check the disk name eg sda2 or sda3 of the EXT4 volume and select the correct one in the bottom left corner
click on install now and all works perfectly,

An external SSD on a thunderbolt port gives very good performances,

but something’s not working… or has your audio been resolved?

First, disconnect any external audio devices from your computer. Also disconnect any cables from the USB, Thunderbolt, FireWire, or 3.5mm audio ports.

Apple suggests removing all cables including thunderbolt cables while troubleshooting audio trouble. Please try unplugging the thunderbolt drive and boot directly from the USB installer. Don’t install the OS overtop your macOS, just test it.

Hi again

just tried Solus, same

One thing I don’t understand
MacOs has discontinued OpenGl/OpenCL in Catalina which means my graphics card is no longer recognized by Blender 2.8 if I want to use it to render eevee. This is to force everyone to use Metal but Blender guys don’t seem to give a hoot.

I installed Windows 10 ( UUUURGH ) and everything worked well in blender with the ATI RADEON 575 PRO
So I thought that a linux bistro would do the same and it doesn’t.
Even after forcing an install of the AMD driver instead of the one in linux it still doesn’t show up in Blender.

I seem to be destined to install an ugly OS like windows just to have that one feature.

I don’t think it’s worth it

So bye bye Ubuntu

well, if you’ve gone this far down the rabbit-hole without any success, try Manjaro? It’s a rolling release of Arch Linux. This looks promising:

https://wiki.manjaro.org/Configure_Graphics_Cards

https://manjaro.org/download/#budgie

Hello

OK Linux has still got a long way to go before non-savvy techs can take it in.
Manjaro seems really good but alas, no sound coming out of the speakers. I did get the ATI card to install a non xorg version but that ended up in a black screen boot up., no way of force booting seeing that the keyboard is a macintosh

Coming from the Mac world where everything JUST works, it’s a little dissapointing. I actually really like the way one can totally customize KDE or Ubuntu, but I’m not ready to go back to school and start to learn programming just to get my sound card to work.

If someone finds a way to get the sound and ATI Radeon cards to work on an iMac 2017 27" I will be much appreciated.

Untill then I’ll stay on my mac…