Ubuntu Budgie on Imac 2017 No Sound


I have been a Mac user for many years and am recently getting interested in Linux
I have been able to install Ubuntu on an old MacBook and it works fine

I have installed Ubuntu 20.04/Kubuntu/DDE/Deepin/Elementary on an external SSD on my iMac 2017 27’’ and no sound.
And now I’ve tried Ubuntu Budgie ,
It’'s really beautiful and I would really like to start using it

Unfortunately like with all the other distros, the internal speakers will not work,
I have tried everything in the book/internet options imac27/alsamixer/pulseaudio etc etc and nothing

My bluetooth headphones work fine.
The strange thing is that alsamixer recognizes my CIRUS audio card/ATI HDMI ( that I don’t use ) and when I run some video the sound sliders move, I’ve tried a lot of internet fixes and just nothing.

So if there is a kind developer or Ubuntu savvy that can give me a hand it’ll be much appreciated.

Bit difficult really to answer unless you can also highlight the sort of things you have tried.

E.g. this mentioned the same issue and changing the sound output from digital to analogue helped https://forum.manjaro.org/t/sound-not-working-on-a-2017-imac-27-5k-retina/43638/9

Thanks for the reply

I tried

options snd-hda-intel model=imac27 in /etc/modprobe.d/alsa-base.conf`
as well as imac27_122
options snd_hda_intel model=intel-mac-auto
options snd_hda_intel model=intel-mac-auto index=1,0

alsamixer showing the correct card/unmuted
pulseaudio showing ati/hdmi off and internal card on in audio stereo duplex/output-unmuted
volume bars moving with media playing in chromium and firefox as well as VLC

options snd-hda-intel model=imac27
sudo alsa force-reload 

I even tried one that made me blacklist a few things and that resulted in Ubuntu not booting up anymore, had to reinstall

I have an iMac 2017 27 i7
the sound controller is a
Cirrus Logic CS4206B
AMD High Definition Audio Device for HDMI

I just can’t get Ubuntu to accept the sound through the speakers.

Any ideas…

Alain, please confirm the speakers ARE working with macOS? You post suggests you are booting UB from an external drive, AND that your bluetooth speakers are working. I’m pretty sure there is an audio jack for earphones on the 2017 model - does the earphone jack have audio? I know this article linked sounds like magic thinking, but I did experience speakers working, then not. Your frustration is very real. I tried this:

I know it sounds stupid/simplistic when you read it, but after three tries… I know you certainly wouldn’t want to man-handle your iMac, but my last successful attempt was during an argument with a family member > POP! < Then all of a sudden the speakers were working. All of your current software solutions seems to have come to no avail. My suggestions are to:

• Boot back into macOS and determine if the speakers are working first (software vs hardware)
• Boot into Ubuntu Budgie and search for additional drivers. I always have to go back after the fact for the wifi drivers (like on my macbook). Perhaps it’s the same for newer speakers?
• Lie the iMac down face first and blow some canned air into the audio/ear phone jack. Have a good look with a magnifying glass and a flashlight. Is there hair/goop/shmutz in the port that might be confusing the audio jack? Do you have pets? Your post says:

alsamixer showing the correct card/unmuted
pulseaudio showing ati/hdmi off and internal card on in audio stereo duplex/output-unmuted
volume bars moving with media playing in chromium and firefox as well as VLC

which suggests to me that there is a physical reason you are muted
• Try that stupid sounding hardware solution last. It could very well be you have minutely shifted the audio jack just far enough away from the case, or some other internal physical thing that we can’t visually inspect because the iMac is a closed box.

Is this the 2017 with or without the new T2 security chip?
Anyways, your bluetooth connection seems to have audio consistently: that proves your bluetooth connection is successfully installed/working - A success! Please report back: my intent is to eventually replace the macOS on my current 2011 iMac once all this world crisis is over, and any final solutions you experience may be personally helpful to me :slight_smile:

Alain, it looks like you are installing Ubuntu from your previous mac experience, have you tried the UB Cupertino layout? That Ant Theme is pretty good, eh? You might look up on gnome.org for mcmojave theme by vinceliuice - excellent stuff! Makes my new Ubuntu Budgie install almost exactly the same experience but without Apple’s walled garden approach.


Yes everything is fine in OS X or even Windows 10 when I installed that on the same drive ( but I soon uninstalled it, Windows is so ugly ) , internal speakers and the jack when I use ear phones.
I have no problem with the output

The sound problem is the same whether I install Ubuntu 20.04,UbuntuDDE,Deepinos ( no sound and no wifi)Kubuntu 20.04 and now Ubuntu Budgie.

I have really gone through all the tips and tricks in the internet.

I’ve purged and reinstalled pulse audio/alsamixer. Changed the output from analog input to all the ones possible. I’ve even tired adding the HDMI from my ATI card.

I’ve added all the ```
options snd-hda-intel model=imac27

I even disabled the ati card with pactl set-card-profile 0 off that I already did in the panel 

Nothing works

Thats why I was hoping to get a developer to help me out

On my old 2010 MacBook everything is just perfect out of the box. 

Anyways I'm sick of trying and rebooting its driving me crazy

I'll stick to the bluetooth headphone method


I have done that in my MacBook and yes it’s really beautiful. I particularly like the eye candy that you can add to the windows and styles,

I’m starting to think it might come from the kernel, if someone could explain to me how I can downgrade the kernel to check

This iMac is the 2017 mid June 27’’ 5K i7 4.2 without the T2 security chip

The sliders are all moving showing that te sound is going through but the volume icon is crossed out

Alain, you might try booting w Solus OS. All the other OS you mention are all desktop derivatives of Ubuntu in one manner or another. Solus is built from the ground up, but shares a desktop environment with Ubuntu Budgie. Maybe it would have different audio solutions?


A reason for sticking with an Ubuntu derivative would be the larger repository of program choices, and your familiarity with apt vs eopkg.

If you are thinking it’s a kernel issue, you could try booting with 18.04:


Before you do (it does sound like you have exhausted a lot of options) check with David: how is the kernel different in 18.04.4? I know for a fact the kernel is older in elementary OS 5.1.4 than in the new Ubuntu Budgie 20.04.

18.04 has kernel 5.3 whereas 20.04 has kernel 5.4

If you think it’s a kernel issue then you can try the very latest kernel 5.6 or later

David FF, I always think newest is bestest :stuck_out_tongue:

Alain, do you still have that macbook? How is the audio hardware configuration different? What kernel is installed on the macbook?

Sorry, I just went back and reread your first post: Can you boot Ubuntu Budgie from a USB directly on the iMac, and test the audio from the USB boot drive? Don’t install the OS, just test the audio. I wonder if asking the external drive to activate speakers thru a USB connection is causing an issue.

You could put an .mp3 on a second drive, put the mp3 on the trial desktop and play it with rhythmbox

Alain, I just went and redownloaded the UB20.04 .iso, burnt a copy w Etcher to a USB and booted. Because maybe this current build is missing something?
Well, the audio test worked the way I expected it to on my macbook pro. The audio test speakers, the cheese camera all sounded good.
(Crappy camera resolution, but I think other people are solving that?)
I really think it’s a case of:
1> a dodgey USB external drive connection
2> something is tricking the speakers into thinking you have headphones in the audio jack.


The MacBook in a unibody 2010 with intel audio drivers
I had no problem installing Ubuntu or Kubuntu ( which I prefer ) on it
Only thing was that the NVIDIA 350M driver was not used, Ubuntu used the nouveaux xorg driver which works very well but I couldn’t get Blender 3d to accept it and run the latest blender 2.8
I updated quite easily via the additional drivers menu but every time I ended up with a black screen on start up.
Spent about a week and many reinstalls before finding one kind person that made me change a few lines in one or two files and all worked again, I also needed to hunt the internet to get my brightness keys to work and now all is fuctioning correctly.

Only problem is that the Nvidia card isn’t such a good card to run blender correctly so that’s the reason I’m truing on my iMac high end,

For the sound I’ve given up and am now using the Bluetooth headphones,

I now must get blender to accept the ATI card as an OpenGL card to use eevee correctly
The keyboard doesn’t use the function keys too

Another headache in perspective,

Linux is great but really not very user friendly as soon as you want to do something different,

Thanks, ill try it out

I also have had issues with Apple’s Nvidia cards, I think Apple blacklisted them because Nvidia was giving Apple the b-grade cards.
Did you try booting from USB, not using the external USB drive?


I have installed the 5.68.0 so unless there’s a new one
or if I downgrade to 5,3