Home Store Blog

Vagrant Doesn't Work in 18.04?


#1

Just did a fresh install of Budgie 18.04, and then downloaded/installed vagrant and virtualbox from their websites.

Tried both scotchbox and homestead and both of them just hang at “Waiting for machine to boot. SSH auth method: private key”.

I have already done an ssh-keygen, and have ssh’d into other servers, so I know my key is working.

Please help.


#2

I have not seen (yet) any reports of this. What I suggest is to run ubuntu-bug vagrant from the terminal to report this bug (Or potential bug) upstream. This will collect the info from your system and launch a sub browser to collect additional details. I’m at work, so I can’t test, bit could try later.


#3

Ah when I try running that I get a warning that it’s not an official Ubuntu package.

I couldn’t install Vagrant using sudo apt install vagrant because the version is so old that Homestead (for Laravel) won’t run. Requires Vagrant >=2.1.0

So I installed these versions from their websites:
vagrant_2.1.1_x86_64.deb
virtualbox-5.2_5.2.12-122591_Ubuntu_bionic_amd64.deb

I did get homestead to work once by manually doing

vagrant init laravel/homestead
vagrant up

but upon doing a vagrant reload I can never get back in again. Just sits at SSH auth method: private key.


#4

@bashfulrobot made an issue on vagrants github about it. Hopefully someone there eventually responds. About to have to install Vanilla Ubuntu 18.04 (blah) so I can get back to work.


#5

Solved it!

My motherboard is an “MSI X370 Gaming Plus”. Virtualization was enabled, however so was “CPU Game Boost” which boosts CPU speed by 200mhz. Despite no mention of this in the guide for the board, this actually breaks virtualization.

Disabling “CPU Game Boost” completely fixed all my Vagrant issues. Oy lol


#6

That’s awesome! Glad you resolved it!!