Volume up-down, calculator, ctr-ALT T, windows key + A and more, not working

Interesting observation:
In the keyboard settings I’ve deleted the ctrl + alt + T shortcut for the terminal, so it is not defined (Because it didn’t work most of the time). I’ve also added a new shortcut to run tilix via ctrl + alt + R. After that I could start tilix via the new shortcut.

Now after reboot a funny thing happened: The shortcuts in the keyboard settings are still defined as I left it. However, now the tilix shortcut with Rdoesn’t work anymore, but the combination with T works, although it isn’t defined anymore. :sweat_smile: There seems to be another service at work. I’ll try to set the keyboard input to none as suggested.

I had something similar, it did not recognize self-defined shortcuts. But changing the keyboard input fixed all these issues. Is there any downside selecting none instead of IBUS?

1 Like

I have two keyboard languages in my system (Japanese and Spanish), and I need them for my daily basis. The configuration will be messed up if I deselect iBus?

Yes, I think you will have problems with Japanese input without iBus.

This is not really a solution, just a workaround. I also need iBus and nohup budgie-wm --replace & does nothing for me.

This has been an intermittent problem for a long time, but seems to have resurfaced again for me in the last couple of days. None of my shortcuts work and (as of today) bizarrely some programs refuse to start (nemo, quotlibet, clementine, audacity). I may have to boot Solus to get anything done.

1 Like

I’m having an odd issue with shortcuts, but I’m not sure if it’s related to this. After a minimal install of Ubuntu Budgie some shortcuts work and some don’t. For instance, I can use ctrl-alt-left/right to move to different workspaces, but Super-PageUp/Down (Move Workspace Up/Down) or a remapped Super-Shift-Left/Right (Move WIndow to Workspace Up/Down) does not work. Some custom keymappings work, for instance, I can explicitly move wondows to a workspace with Super-1/2/3/4. Curious if there are any suggestions to debug keymapping problems?

I just did this after the volume hotkeys stopped working on a fresh 18.04 install.
Worked a treat!

With the very latest 19.04 (full up-to-date) I have added a patch that needs testing to see if this resolves these issues.

So please do give it a try and let me know if this is still an issue. Note please DON’T do the workarounds above (manage installed languages / restart budgie-wm).

If there is positive feedback I will definitely backport the fix + throw it upstream as well.

Media keys started working fine here, thank you.

I’ll have to test this on my install. My automation scripts auto apply the fix, so I currently have that enabled on my 19.04 machine.

I just experienced this issue :C, sorry but I read this post sequentially and did the workaround already :sweat_smile:

And just for clarification, did that work around solve the issue for now?

It worked after doing it, not a permanent fix.

Having the same issue of shortcuts not working (e.g. print screen, window switching) after latest sudo apt-get upgrade on my system, and confirming that the below command temporarily fixes it:

^^^ that is a better workaround if you dont need to use multiple keyboard layouts

thanks, disabling ibus seems to work. will keep an eye on this.

I defined a shortcut to shutdown my machine and then sometimes it worked and sometimes it didn’t. I wasn’t able to determine what causes it not to work.

settings -> region&language and there, click on “manage installed languages” then changed “keyboard input method system” to none instead of ibus. Logout and login.

finally did the trick.

Everyone - I have a tentative real fix for 19.10 users - I need people to test please and to let me know - good or not so good if this issue is finally fixed.

So please readd the IBUS keyboard input method (you will have set this to None) in settings -> region&language, click on “manage installed languages” then change “keyboard input method system” to ibus instead of none. Logout and login.

sudo add-apt-repository ppa:ubuntubudgie-dev/desktopkeygrab
sudo apt-get upgrade
reboot --

Since this is such an intermittent issue - you’ll need to do your regular routine’s - suspend/reboot - whatever you need to-do. Just check regularly if shortcut’s and media keys stop working.

To remove the PPA:

sudo ppa-purge ppa:ubuntubudgie-dev/desktopkeygrab
reboot --

TIA

1 Like

Continuing the discussion from Volume up-down, calculator, ctr-ALTl T, windows key +A and more, not working anymore:

Hi all,

I am a new Linux user in general and am experiencing this issue as well. I installed Budgie 18.04.3 a few days ago and updated with apt update apt upgrade.
Here are some of my symptoms, if they are of any help:
Screen brightness media keys (F11 and F12) work without pressing Fn key. Pressing Fn+F12 opens a terminal with max horizontal width snapped to the top of the screen.

I use Bulgarian input as well, but not sure if I need iBus input method system.
Switching to ‘none’ with logout/login does nothing for me. nohup budgie-wm --replace & fixed the default shortcuts for launching Tilix and Nautilus, but didn’t help for the media keys.
I will do some more attempts with the workarounds and see if there are any results.

Hi and welcome,

this issue is very specifically about keyboard shortcuts that seemingly disppear after a logon - but reappear on another login.

So your observations are perhaps another issue. F12 is a mapped customer keyboard shortcut to open tilix in quake mode. The fact that Fn is/isn’t required is odd but I’m guessing is an issue with your keyboard hardware not being correctly recognised. Suggest raise this a bug-report to launchpad by typing the following in a terminal.

ubuntu-bug linux

I’m just getting around to this - just reenabled ibus and put the test PPA on.