Home Store Blog Development

Volume up-down, calculator, ctr-ALTl T, windows key +A and more, not working anymore


#42

I had the same problem as you. Did you do a default install or a minimal? Mine was presented at minimal and fix was going full via aptitude.


#43

I’m still running minimal. However, I recently published a blog post about layering up from minimal to get the “UB” experience. I wonder if that is related.


#44

I went with the full install, alongside Solus. I think the shortcuts broke after the first reboot.


#45

Does this occur when people have multiple keyboard layouts defined (Menu - Region & Languages - Input Source) ?

To be honest - I’m not a big keyboard shortcuts person … but I’ve never seen this issue before so can’t help much other than asking rather odd questions!


#46

I installed UB 18.04 fresh on two machines: A dell laptop and my desktop machine.
I noticed that on my desktop the terminal shortcut is not working (ctrl + alt + t). On the laptop it’s working fine. Both machines have the same keyboard configuration.


#47

Was this a minimal, or full install?


#48

full install on both


#49

Well there goes my theory! ha ha. Just as an FYI, There are upstream bugs reported.


#50

I too am having this issue on a fresh, full install of 18.04.
I tried rebinding the shortcut keys to different combinations and also resetting them, but the problem persisted.


#51

There has been various reports over the years of keyboard shortcuts stop working. Earliest example from a quick Google was gnome 3.4 days.

So it does seem to be a persistent issue that has had various attempts to resolve but it keeps coming back to haunt various folk.

E.g.

https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1224732

If you can please use your Google fu and see if you can search through various reports to see if there is anything that can be gleaned as to what has been tried and possibly still works in 18.04.


#52

I am currently experiencing this, but I see nothing odd in there other than some apparmour stuff related ot snaps.


#53

@fossfreedom You asked how many reboots to get back shortcuts back… seems to be one for me.

The only thing I can see - this is coming out of an extended suspend.


#54

Dustin. Uninstall tlp … lets see if it’s a power management issue.


#55

@fossfreedom I am using multiple keyboard on this box for a while now to test… but the issuie never happened again, (un)fortunately.


#56

Thanks for the confirmation. Just foçussing on the deep suspend observation. If it is power management then could be tlp or kernel or systemd.

So if it’s not tlp then worth seeing if kernel 4.13 works better… I.e. the artful kernel. I don’t think we have seen this observation with 17.10.


#57

@fossfreedom Removal of TLP made no difference. And I just had it happen after a fresh boot up. So supend was not the cause in this particular case.


#58

ok - I’ve taken the artful gnome-settings-daemon and simply rebuilt for bionic. Can’t guarantee any stability etc but please give it a try to see if it resolves this

sudo add-apt-repository ppa:ubuntubudgie-dev/gsd 
sudo apt update && sudo apt upgrade

To purge the PPA:

sudo ppa-purge ppa:ubuntubudgie-dev/gsd

#59

As an alternative for the above does logging off/logging on OR restarting the window manager kick keyboard control back into life?

nohup budgie-wm --replace &

#60

I’ll try the wm method first, then if it does not help, I’ll try the PPA


#61

Oops didn’t have the problem for weeks ( I have a desktop) but it’s back… I will read your tips / tricks and work around here to see if it help… I can’t use several keys ( volume up /down, SUPER D, change workspace shortcut and more)

JF