Home Store Blog Development

Volume up-down, calculator, ctr-ALTl T, windows key +A and more, not working anymore


#62

nohup budgie-wm --replace & WORKED FOR ME
JF


#63

Thanks for posting that! I have not had it yet, so I have not been able to troubleshoot or attempt.

@fossfreedom - Thoughts? That sounds “budgie-esk” does it not?


#64

Correct. This should be reported upstream with a summary of the issues what we have tried and the current workaround.

Sounds like there is a definite gnome settings daemon race condition here on start of the entire window manager process.


#65

YEP! I can confirm jfbourdeau’s nohup budgie-wm --replace & works! I just had the issue immediately after a restart on my laptop (no additional layouts). Tried the command and all works again.


#66

confirmation that this issue is not a specific Ubuntu Budgie issue - https://github.com/solus-project/budgie-desktop/issues/1449 i.e. confirmed that affects Manjaro


#67

When I reported the bug, I reported it on both Launchpad and on the gnome bug tracker.


#68

Just wanted to add that adding this command

nohup budgie-wm --replace &

to the startup applications allows it to work from bootup. I will keep you posted if it cuts out at a later time during normal operation.


#69

Thanks a ton Rocco! One thing to note for the other people in this thread, I’ve assigned the keyboard shortcut to the command… That way it’s super easy to run off the top of your head.


#70

I am not sure to get it / understand
for now I manually run nohup budgie-wm --replace from time to time


#71

Basically if you are having the problem where your keyboard shortcuts are not working… Run that command. By resetting the window manager, the issue goes away.


#72

For clarification, it goes away at least temporarily. If it pops up again, you would need to run the command a subsequent time.


#73

Reported via IRC:

gnome settings -> region&language and there, click on “manage installed languages” then changed “keyboard input method system” to none instead of ibus. Logout and login.

Seemingly this fixes this issue. Can anyone do this and verify?


Nemo "open in terminal" does not work
Keyboard Keys ( CTRL -T, move to other workspace etc) forgot how to fix it
#74

I will try and let you know…

For now I was running the command mentioned above in the thread, from time to time to fix my problem,…
JF


#75

@foss[quote=“fossfreedom, post:73, topic:140, full:true”]
Reported via IRC:

gnome settings -> region&language and there, click on “manage installed languages” then changed “keyboard input method system” to none instead of ibus. Logout and login.

Seemingly this fixes this issue. Can anyone do this and verify?
[/quote]

I made the change - waiting to see if it comes back again…


#76

For now it seam to work for me

But I also noticed a recent update (gnome I think) relating to the same thing…

JF


#77

I must have missed that. Sounds interesting - might be worth running with this for a while … and then later switching back to see if the recent update has fixed this properly.


#78

Since trying the region and language thing, no issues here yet either. I want to know how someone thought of trying that as a fix…


#79

What this is telling me is that it is more likely to be a race condition between ibus and gnome settings daemon. Both intercept keystrokes. Given the history I have seen this goes back to the early gnome 3 days 6, 7 or more years ago. Why 18.04 is particularly prone to this I am not sure


#80

Interesting observation:
In the keyboard settings I’ve deleted the ctrl + alt + T shortcut for the terminal, so it is not defined (Because it didn’t work most of the time). I’ve also added a new shortcut to run tilix via ctrl + alt + R. After that I could start tilix via the new shortcut.

Now after reboot a funny thing happened: The shortcuts in the keyboard settings are still defined as I left it. However, now the tilix shortcut with Rdoesn’t work anymore, but the combination with T works, although it isn’t defined anymore. :sweat_smile: There seems to be another service at work. I’ll try to set the keyboard input to none as suggested.


#81

I had something similar, it did not recognize self-defined shortcuts. But changing the keyboard input fixed all these issues. Is there any downside selecting none instead of IBUS?