Volume up-down, calculator, ctr-ALTl T, windows key +A and more, not working anymore

I have two keyboard languages in my system (Japanese and Spanish), and I need them for my daily basis. The configuration will be messed up if I deselect iBus?

Yes, I think you will have problems with Japanese input without iBus.

This is not really a solution, just a workaround. I also need iBus and nohup budgie-wm --replace & does nothing for me.

This has been an intermittent problem for a long time, but seems to have resurfaced again for me in the last couple of days. None of my shortcuts work and (as of today) bizarrely some programs refuse to start (nemo, quotlibet, clementine, audacity). I may have to boot Solus to get anything done.

1 Like

I’m having an odd issue with shortcuts, but I’m not sure if it’s related to this. After a minimal install of Ubuntu Budgie some shortcuts work and some don’t. For instance, I can use ctrl-alt-left/right to move to different workspaces, but Super-PageUp/Down (Move Workspace Up/Down) or a remapped Super-Shift-Left/Right (Move WIndow to Workspace Up/Down) does not work. Some custom keymappings work, for instance, I can explicitly move wondows to a workspace with Super-1/2/3/4. Curious if there are any suggestions to debug keymapping problems?

I just did this after the volume hotkeys stopped working on a fresh 18.04 install.
Worked a treat!

With the very latest 19.04 (full up-to-date) I have added a patch that needs testing to see if this resolves these issues.

So please do give it a try and let me know if this is still an issue. Note please DON’T do the workarounds above (manage installed languages / restart budgie-wm).

If there is positive feedback I will definitely backport the fix + throw it upstream as well.

Media keys started working fine here, thank you.

I’ll have to test this on my install. My automation scripts auto apply the fix, so I currently have that enabled on my 19.04 machine.

I just experienced this issue :C, sorry but I read this post sequentially and did the workaround already :sweat_smile:

And just for clarification, did that work around solve the issue for now?

It worked after doing it, not a permanent fix.

Having the same issue of shortcuts not working (e.g. print screen, window switching) after latest sudo apt-get upgrade on my system, and confirming that the below command temporarily fixes it:

^^^ that is a better workaround if you dont need to use multiple keyboard layouts

thanks, disabling ibus seems to work. will keep an eye on this.

I defined a shortcut to shutdown my machine and then sometimes it worked and sometimes it didn’t. I wasn’t able to determine what causes it not to work.

settings -> region&language and there, click on “manage installed languages” then changed “keyboard input method system” to none instead of ibus. Logout and login.

finally did the trick.