Windows management + super key issues

Not sure what grey square you mean, when using alt-tab? If so, did you activate it via the main menu?

yes it’s the alt-tab square gray, when is use the shortcut, he just show the square when he should show the open windows. I left it activated through the main menu, through the program previews control

I have requested feedback for this suggested fix that is your issue here

Thanks, I’ll read this topic, and I tell yoy if solve my problem

I must say, didn’t run into an issue like this before, unless something wrong went wrong with installing. A few questions: is this a full, default fresh install or an update? To catch a possible error, could you, directly after log in, ope a terminal and run pkill -f '/lib/budgie-previews/previews_creator', after that: '/lib/budgie-previews/previews_creator' and keep the terminal open? If the issue occurs, please post the output.

apparently this tip didn’t work much about the super key problem

the preview control problem didn’t occur after I ran these two commands, the predictions usually

This problems, this a few moments, continue occurring

Just an idea, but about the previews issue, if it occurs, is it immediately starting after log in?

No, it’s sometimes after a while in login

Then the only option to catch the error is to run the commands I suggested for a while I am afraid, until the error occurs. Would be really helpfull, since we have no other info, nor known other occurrence of the issue.

Ok, I’ll take the commands and tell here what happen when the error occurs

One strange thing that you notice about a keyboard window is that it doesn’t open, but when the menu opens, it closes with a key.

So, I did it and take this problem in the terminal:
(previews_creator:18863): Gdk-CRITICAL **: 21:06:25.124: gdk_pixbuf_get_from_window: assertion ‘gdk_window_is_viewable (src)’ failed

** (previews_creator:18863): CRITICAL **: 21:06:25.128: create_previews_determine_sizes: assertion ‘pre_shot != NULL’ failed

(previews_creator:18863): Gdk-CRITICAL **: 21:25:25.453: gdk_pixbuf_get_from_window: assertion ‘gdk_window_is_viewable (src)’ failed

** (previews_creator:18863): CRITICAL **: 21:25:25.453: create_previews_determine_sizes: assertion ‘pre_shot != NULL’ failed

(previews_creator:18863): Gdk-CRITICAL **: 21:47:41.307: gdk_pixbuf_get_from_window: assertion ‘gdk_window_is_viewable (src)’ failed

** (previews_creator:18863): CRITICAL **: 21:47:41.311: create_previews_determine_sizes: assertion ‘pre_shot != NULL’ failed

I’n still don’t know how to fix the super button problem

Trying to understand what is happening… Just to make sure, yoiu are using the pre-installed version of previews, right? You didn’t install it (again) or anything like that?
If it happens, any particular application running? Any particular activity orevent?

Could use a test “window.is_viewable()” and if not true then do something to not further process the match window - think that will stop further issues below that in the if statement.

Also https://valadoc.org/gdk-3.0/Gdk.pixbuf_get_from_window.html (https://github.com/UbuntuBudgie/budgie-extras/blob/master/budgie-wpreviews/src/previews_creator.vala#L202) says that the function itself can return NULL - so the code could have a defensive “if returnval is null” type statement rather than assume stuff is valid

I don’t know if my version is the pre-instalated, I just installed the sistem of the zero and didn’t nothing to the previsualizations.

We did & tried all that during development, but the possible time between destroy and check-for-existence was a dealbreaker. We fixed it then by error_trap_push() which even returns a result on (just) destroyed window. No clue why that does not work in op’s case. Never had a single issue. Would be interesting to find out if a specific event or window type is in the picture.

@Bird12 Would you share your hardware / specs with us? As said above, the attempt to create a window preview crashes if the window does not exist (any more). Most of the time that will be only a very tiny split second between checking on the window and actual preview creation. This is fixed in the code by using Gdk error_trap(). So far, this is the first case as far as I can see where error_trap does not do the job, which make me wonder:

  • does this happen on a specific type of window?
  • does this happen on a specific type of hardware?

If you’d be willing to share, would be much appreciated.