Home Store Blog Development

WOL not working


#1

Hello
I can’t get wake on lan working, Ubuntu Budgie 18.04 beta 1 or 2.
Multi boot system Winxp on sda1, Kali rolling on sdc5, Ubuntu 17.10 on sdc6, Ubuntu 18.04 beta 2 on sdc8, and Ubuntu Budgie 18.04 beta 2 on sdc9.
When I shut down any other OS and try to WOL, the magic packet works and Grub2 is started. Budgie ,however, gives no response.

I have tried:
ifconfig - found out my Ethernet is “enp0s25”
sudo ethtool enp0s25 - and learned “Supports Wake-on: pumbg” but “Wake-on: d”
sudo ethtool -s enp0s25 wol g - then
sudo ethtool enp0s25 - shows “Wake-on:g”
cat /proc/acpi/wakeup - shows “ILAN S4 *disabled pci:0000:00:19.0”
I then ran - sudo echo ILAN | sudo tee /proc/acpi/wakeup
now - cat /proc/acpi/wakeup - shows “ILAN S4 *enabled pci:0000:00:19.0”
Shutdown and still nothing.
Any ideas what to try next?


#2

Any of this applies?

https://kodi.wiki/view/HOW-TO:Set_up_Wake-on-LAN_for_Ubuntu

Other than that this maybe a general Ubuntu question like this could find an answer of either ubuntuforums.org or askubuntu.com


#4

Had to change WOL_DISABLE=Y to WOL_DISABLE=N in /etc/default/tlp