Budgie dead slow bootup and laggy

so it’s been sometime since my ubuntu has been slowing down but i’ve been working on windows continuously for like 4 months now (using throttlestop, cos it’s old). Came back to budgie today and i literally had to wait for like 5 mins for everything to start up and then more when i restored tabs in chrome. I browsed the forum and found this - Why is budgie so slow when booting up?

so here’s the output from systemd-analyze blame

2min 42.043s apt-daily-upgrade.service
2min 7.276s fstrim.service
1min 5.148s plocate-updatedb.service
23.632s snapd.service
19.617s apt-show-versions.service
17.942s dev-loop31.device
10.965s fwupd-refresh.service
7.710s NetworkManager-wait-online.service
2.243s dev-nvme0n1p8.device
2.174s dev-loop4.device
2.164s dev-loop0.device
2.164s dev-loop6.device
2.097s dev-loop2.device
2.094s dev-loop1.device
1.915s snapd.apparmor.service
1.711s man-db.service
1.701s logrotate.service
1.666s apt-daily.service
1.382s docker.service
1.357s ua-timer.service
1.215s boot-efi.mount
1.149s udisks2.service
1.080s bluetooth.service

why is this taking so much time? Really miss the swiftness. Please help

The top culprits are all drive related services.

Probably should concentrate efforts there.

Look at the drive health in gnome-disks.

Possibly try running a fsck via a usb live session.

If this is a dual boot with windows try turning off windows fast boot

sure, i’ll try them. Meanwhile I also ran conda search --outdated and it gave me so many packages that’re still in my system.

small snippet

zstd 1.5.2 ha95c52a_0 conda-forge
zstd 1.5.4 hc292b87_0 pkgs/main
zstd 1.5.5 hc292b87_0 pkgs/main
zstd-static 1.4.5 he1b5a44_2 conda-forge
zstd-static 1.4.5 he6710b0_0 pkgs/main
zstd-static 1.4.8 h9c3ff4c_0 conda-forge
zstd-static 1.4.8 h9c3ff4c_1 conda-forge
zstd-static 1.4.9 h9c3ff4c_0 conda-forge
zstd-static 1.5.0 h9c3ff4c_0 conda-forge
zstd-static 1.5.1 h9c3ff4c_0 conda-forge
zstd-static 1.5.2 h27087fc_1 conda-forge
zstd-static 1.5.2 h27087fc_2 conda-forge
zstd-static 1.5.2 h27087fc_3 conda-forge
zstd-static 1.5.2 h27087fc_4 conda-forge
zstd-static 1.5.2 h9c3ff4c_0 conda-forge
zstd-static 1.5.2 hcb278e6_5 conda-forge
zstd-static 1.5.2 hcb278e6_6 conda-forge
zulip 0.8.2 pyhd8ed1ab_0 conda-forge
zwatershed 0.8 np110py27_0 conda-forge
zwatershed 0.8 np110py27_1 conda-forge
zwatershed 0.8 np110py27_2 conda-forge
zwatershed 0.8 np111py27_0 conda-forge
zwatershed 0.8 np111py27_1 conda-forge
zwatershed 0.8 np111py27_2 conda-forge
zwatershed 0.8 np111py27_3 conda-forge
zwatershed 0.8 np112py27_2 conda-forge
zwatershed 0.8 np112py27_3 conda-forge
zwatershed 0.8 np113py27_2 conda-forge
zwatershed 0.8 np113py27_3 conda-forge
zwatershed 0.8 py27_4 conda-forge
zwatershed 0.8 py27_5 conda-forge
zwatershed 0.10 py27_0 conda-forge
zwatershed 0.10 py27h1ef8b13_1 conda-forge
zwatershed 0.10 py27h4881e95_1001 conda-forge
zwatershed 0.10 py27h5c5fb89_1 conda-forge
zwatershed 0.10 py27h86cc20e_1002 conda-forge
zxpy 1.2.4 py36h5fab9bb_0 conda-forge
zxpy 1.2.4 py36hd000896_0 conda-forge
zxpy 1.2.4 py37h89c1867_0 conda-forge
zxpy 1.2.4 py37h9c2f6ca_0 conda-forge
zxpy 1.2.4 py38h578d9bd_0 conda-forge
zxpy 1.2.4 py39hf3d152e_0 conda-forge

how do i get rid of this? cos conda also has been very slow for me, and it’s not just at startup

Sorry - I can’t help with the above - this isn’t something we ship with and thus we aren’t familiar with.

Perhaps a wider ubuntu audience could help? askubuntu.com / ubuntuforums.org

so i disabled fast boot and it really made a difference! but why?! I’d like to have fast boot so that i can seamlessly switch between windows and ubuntu. I can switch and have my windows exactly the way it was previosuly, but couldn’t have that in ubuntu, and i really wanted some feature like that. Now this feels more like a setback.

7.332s NetworkManager-wait-online.service
5.125s snapd.service
2.685s fwupd.service
2.406s dev-loop7.device
2.382s dev-loop6.device
2.365s dev-loop4.device
2.359s dev-loop5.device
2.338s dev-loop3.device
2.246s docker.service
2.244s dev-loop2.device
2.223s dev-loop0.device
2.218s dev-loop1.device
2.096s dev-nvme0n1p8.device
1.156s boot-efi.mount
1.085s snapd.seeded.service

the disk is not damaged, i’ve a 1tb ssd, windows, ubuntu and my data drive are all partitions of this disk. Anything else that i can do to speed up in terms of ubuntu? cos i definitely need to do something about conda

It kind of depends on your setup why fast-boot disabling makes a difference.

If you have a fstab entry to mount a windows partition this will be an issue since fast-boot interferes with mounting.

I think encrypted drives are impacted as well. Probably other issues as well - this isn’t an area I use since I don’t dual boot with windows.

GNU nano 6.2 /etc/fstab

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

/ was on /dev/nvme0n1p8 during installation

UUID=f604cfc7-05e6-4dc7-b196-7ab29607d4b5 / ext4 errors=remoun>

swap was on /dev/nvme0n1p6 during installation

UUID=209085e9-7e45-47e5-a33c-93c3f90b44c0 none swap sw >
UUID=5EC1-8F1B /boot/efi vfat defaults 0 1

this is my fstab reading, i don’t understand this, but is there anything I can do about this to enable fast boot? One more thing is, i can access my windows files from ubuntu but can’t do the reverse, Idk if it’s a type problem or a problem with the way i installed it. My laptop is a windows native one, but I installed ubuntu and gave it priority such that i get the GNU GRUB option after booting that lets me select the OS i want to use.

When fast boot is enabled on Windows, it’s somehow a kind of « hibernate » mode :
⋅ the current states of your activities is stored somewhere ( pagesys file or something like this ) ;
⋅ partitions are marked readable only ( to avoid modifying your previously stored state of things ).

Your fstab is normal and shows which ( filesystems in ) partitions are mounted when booting your Linux OS :
⋅ the root system /
⋅ a swap partition ( it could be a file instead )
⋅ and a partition needed for booting in (u)EFI mode.

I presume ( need check ) that EFI partition is the only « common » part between your two OSes.
If enabling fastboot on windows slows down Ubuntu boot, it’s probably related to it.

And unfortunately, only way to avoid Windows for « preempting » partitions is to disable fastboot ( which means really stop Windows system, not just « hibernate » it ).

Maybe using another boot manager like ReFind ( instead of GRUB ) would provide a workaround, I don’t know.

Normal. Linux knows how to read / write on NTFS filesystem but Windows refuses to implement EXT4 capabilities because king Windows does not want you to leave its realm.

If you need common data between your 2 OSes, you should store them on a filesystem ( in a partition ) both OSes can deal with : ExFat or NTFS. Or store data in a NAS.