Icon gThumb Image Viewer missing

My fellow Budgie users, I need your help. I have just realised that I am missing the icon for the gThumb Image Viewer and I have no idea where it has gone and how to get it back.

What did I do today before I noticed that the icon had disappeared? I changed the language of my Ubuntu Budgie system from German to Dutch today. Then, with the help of Budgie Welcome, I switched back from the Mojave theme I tried during yesterday to the Plata theme I used before. I then noticed the absence of the icon. Unfortunately, restarting the system did nothing. The icon is still missing. Strangely enough, it is now also missing in other themes, so not only in Plata. And only the gThumb icon is missing. All other icons are there.

Have you already experienced something like this? How can I get the missing icon back?

PS: I’m not sure in which category my question belongs. I’ll put my question in the Themes category for now. If it doesn’t belong there, feel free to move it to another category.

What is your Ubuntu (Budgie) version? This is/was an issue with the. desktop file of gthumb (incorrect Icon= line on certain languages). I raised an issue quite a while ago, and it was fixed. Not sure in which Ubuntu version the fix is released though.
We can fix it manually however. I need to be at my box, will post the fix this weekend.

Ok, here we go:

  • Please run sudo -i gedit '/usr/share/applications/org.gnome.gThumb.desktop'
    The .desktop file will open in gedit after you entered your password.
  • Look for the line: Icon[nl]=gThumbhttps://gitlab.gnome.org/GNOME/frogr
    The line obviously makes no sense.
  • Replace it with: Icon[nl]=gthumb

…and you’re done.

P.S. I am noticing it is still not fixed on 20.10, which is odd. link: Dutch translation - gThumb icon line in .desktop file incorrect - no icon (#91) · Issues · GNOME / gThumb · GitLab

Thank you very much for your quick reply. So the problem is due to the system language used? Who would have thought that! And I had already thought that I had damaged the system when I changed the theme. Phew, that’s a relief! By the way, I use the Ubuntu Budgie LTS version 20.04.2, which is always kept up to date, so the fix should not have been included in the LTS version yet. I’ll apply the fix right away and report afterwards whether it worked.

I applied the fix and not only did it work flawlessly, it worked immediately! The icon was back in an instant. Thanks again for the quick help. :smiley:

1 Like

Thanks for mentioning!

1 Like

Hi, out of topic, just for my knowledge : why

and not

gedit admin:///path/to/file

?

…Because I am a traditional guy :). But for reasons of consistency: why involve GUI elements if we don’t need to and we are working from the cli already?

:smile: I’m just worried it might serve as a bad example for some to open « graphical » app’ with
sudo windowed-app
not noticing the -i option you carefully used. Then is -i better than -H ?

And if aiming CLI consistency why not sudo nano /path/to/file ? :smiley: