[22.04] Cannot start Viber for desktop

As title said. Switched today from Kubuntu 20.04 to Budgie. When I run Viber, it cannot start, popup error Send… Tried from terminal, says Aborted (core dumped).

Any help?

Hello @Bebac and welcome to our discourse.
22.04 was just released, it is likely that Viber needs an upgrade for 22.04 compatibility.
I tested the .deb package and I can install it, and on first run Viber complains that I don’t have internet access, and I need it to use Viber. And since I am typing this message, I am quite sure I do have internet access :grinning:

Having said that, Viber comes in appimage, there is also a flatpak and a snap. You can switch to one of those 3 until Viber debian package gets updated to work well with 22.04.

1 Like

Thanks for welcome! :smiley:

Managed to get it to work. 1st, didn’t start at all (installed .deb version). AppImage too.
Fixed by installing libqt5. Then internet connection comes to question. Found that viber uses some old openssl libraries, tried openssl1.0.0, didn’t work.
Per reddit post, this one fixed problem:
But, need to change exec line in nano /usr/share/applications/viber.desktop
Exec=LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libssl.so /opt/viber/Viber %u

That also didn’t work for me. What worked is symlink libssl 1.1 with viber one:
sudo ln -sf /usr/lib/x86_64-linux-gnu/libssl.so.1.1 /opt/viber/lib/libssl.so.1.0.0

Hope this will help someone, or I hope no one uses this crappy app (I need it for work).


Nice write up.

However just an obvious caution. You are using a security vulnerable library. Especially with an app like viber your are potentially giving access to bad actors via media etc.

Really need viber to fix their app.

1 Like