22.04 / UEFI bios in legacy mode / multi-boot

Hi all,

trying to install 22.04 beside 20.04 and others.

Here are my actual discs and partitions ( sdc is the installation media, an usb thumb made with Ventoy ) :

In installer, chossing « something else » to target sda5 as / with formatting and sdb1 as /media/DATA without formatting, I get this message :

I did not go further, as I need to be sure this won’t explode my actual partitions by adding in my context an useless EFI partition.

What do you think ?

( and why can’t we resize the installer window ? )

To be honest i cant answer your question directly.

However, two observations.

For the resizing issue this is a straightforward issue that can be raised.

ubuntu-bug ubiquity  

from the live usb session.

For the partition question i would take a full disk image … for example using clonezilla … so that you can easily restore the while image.

Or Timeshift, I guess.

Well am very surprised : did nobody try that, multi-boot in non-uefi ? ? ?

Or the idea behind is → you shall use UEFI and nothing else nowadays ?

( on new hardware I agree but for enterprise / in business hardware you have to deal with what’s already there… )

From a dual boot non-efi yeah thats part of the beta testing. No issues.

Specifically you mentioned about it creating a non relevant partition. No idea. Dual booting worked just fine but didnt look to see about additional partitioning.

I received this same warning message when installing 22.04 on an older dual boot Thinkpad that does not have UEFI.

As a potential risk I don’t want to encounter :wink:
This has happened in some contexts with 21.04/21.10 hence my question.

@makitso and does everything still run as expected ? no unneeded EFI partition afterwards ?

I dont have duel boot.
I got the same notification, when I did a new install in January and I clicked to continue.

No issues

lsblk -fe7 -o +size
NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINTS SIZE
nvme0n1 465.8G
├─nvme0n1p1 vfat FAT32 1678-C397 1014.6M 1% /boot/efi 1023M
├─nvme0n1p2 ext4 1.0 736ca5c5-faef-4e5f-ad03-15c4bf947e82 25.8G 29% / 40G
├─nvme0n1p3 ext4 1.0 d2949e6a-c21d-4768-aebc-84ac99e9cfae 51G 21% /home 70.5G
├─nvme0n1p4 swap 1 0dff914f-899d-4c18-8566-d8cee8ed7ff9 [SWAP] 9.5G
├─nvme0n1p7 ext4 1.0 Chaz-Storage-19 c8472a2e-9717-4ae0-abcc-98b88e7c5cc5 53.7G 35% /media/chaz/Chaz-Storage-19 90G
└─nvme0n1p8 ext4 1.0

@ Coeur-Noir Yes, I selected “continue at your own risk” option and it installed correctly.

I can’t speak with authority, but I see the message

“No EFI System partition was found. This system will likely not be able to boot successfully, and the …”

somewhat regularly (both with ubiquity & calamares with Ubuntu & flavor installers), and it’s not a problem if the box is legacy and not using uEFI/Secure-uEFI to boot. There are a number of reasons why the message can occur, and can be influenced by how you wrote the ISO to thumb-drive (I have no experience with ventoy so have no idea how it wrote it)

Thanx all of you for your confirmation and success, now I feel relieved and confident :wink: for next step.

@guiverc from my understanding, ventoy seems to write an UEFI-ready media. So as it’s running in that mode that may very well explain why the installer expects / leads to an UEFI installation.
Although partition tables are in mbr/dos… maybe installer doesn’t look that further.

I confirm installation with ventoy thumb in non uefi mode, using « other thing » for targeting partition for /

Also have some problems with language settings :


this is after installation, no way to change anything in Budgie Control Settings regarding languages.
By chance here keyboard mapping is correct, azerty / french ( alt ).

During trying in live-usb-session keyboard was in qwerty instead of azerty in most app’s - by chance it was azerty in ubiquity. But no way to change it because of inability in Budgie Control Center.
It’s an old problem in most Ubuntu flavors which does not occur in official Ubuntu.

Other problem encountered : leaving session gets me back as expected on lightdm but resolution broken afterwards, even in regular session.

do make sure you are up-to-date - BCC in this area has had an important fix since out of the box the language was fixed to English US

Unable to check because of resolution issue, I can’t drag windows beyond top panel…

Here I suspect Ubiquity has installed some nvidia driver, but I can’t go back to nouveau from this window :
Capture d’écran du 2022-04-30 19-16-55
⋅ says a manually installed driver is in use ( hence my assumption )
⋅ I can’t chose anything else

just drop the panel to another part of the screen via budgie desktop settings.

The last but one option I would have thought would have switched to Nouveau

Yes, but I can’t chose it, nothing happens on click, dead radio buttons probably because of « manually installed driver is in use. »

I shouldn’t have ticked « install 3rd party software and drivers » during installation. Not the first time I struggle with ( old ) nvidia devices…

Ok for resolution after
sudo apt purge *nvidia* ; sudo apt reinstall xserver-xorg-video-nouveau libdrm-nouveau

No change after usual update/full-upgrade/autopurge regarding BCC it says English.
It offers French, lets me select but actually won’t apply.

Have you actually installed the french language via the separate language and region app?

I know all of this works because one tester confirmed by installing dutch and switching between english and dutch and visa-versa. A separate tester confirmed Portuguese install and switching.

Yes I did, first thing done.


You can see here « France » for Formats but actually it never stays in place, at next launch of BCC, it’s America there which comes back.

Also I have removed ( for the moment ) any other language else than French - only basic mandatory English remains.

I did not test long enough to see how or if it affects the system, keyboard mapping is expected azerty + french ( alt ).

BCC version :

ii  budgie-control-center                 1.0.1-2                                 amd64        utilities to configure the Budgie desktop
ii  budgie-control-center-data            1.0.1-2                                 all          configuration applets for Budgie - data files

Is there a way to « reset » BCC ?

What is the debian package version of budgie-control-center installed on your system?

I had to boot on that system as a rescue, which I hadn’t « touched » since.

Many expected updates. Seems ok now, wait and see.