How to install Ubuntu Budgie 20.04.1 in BIOS mode?

I want to add Ubuntu Budgie alongside Linux Mint already installed in BIOS mode (works fine, no EFI System Partition), but UB only allows me to install it in EFI mode. Could you please guide me how to install UB in BIOS mode?

If you clone from the iso file to a USB pendrive, you will get a live drive, that can boot both in BIOS mode and UEFI mode. Which tool did you use to create the USB boot drive?

  • If you boot in UEFI mode, the installer will install in UEFI mode.

  • If you boot in BIOS mode, the installer will install in BIOS mode.

You select boot mode via the computer’s BIOS/UEFI system (either with a temporary menu or via a setting in a menu of the BIOS/UEFI system).

The following link and sub-links may help:

1 Like

Hi @sudodus, thank you so much for the detailed explanation.

I have created live USB first using Etcher and then Startup Disk Creator. Oddly enough, my BIOS/UEFI doesn’t offer any other option for booting this USB except in UEFI mode (no Legacy/BIOS found in the list). Is there a way to circumvent this problem?

Before you do anything else, you should check with md5sum, that your Ubuntu Budgie iso file was downloaded correctly.

My experience with all flavours of Ubuntu 20.04.1 LTS is that USB drives with cloned systems (using Etcher, Startup Disk Creator or any other cloning tool) boot in BIOS mode. So I think the problem is in the computer’s BIOS/UEFI system, that is activated at boot, before starting the operating system (via syslinux in BIOS mode or via grub in UEFI mode).

So what you need is a way to activate boot in BIOS mode alias CSM alias legacy mode. The BIOS/UEFI system varies a lot between computers, so I can’t help with details.

Please tell us about the computer: brand name and model, and if possible also about the BIOS/UEFI system: brand name and model. If you are lucky, someone with the same or similar computer may recognize the problem and help you.

I think your problem is not specific for Ubuntu Budgie, and if nobody can help you here, you can ask at AskUbuntu or the Ubuntu Forums, where a wider group of users/helpers will see your question.

1 Like

Did so already, everything’s fine on that end.

Most definitely, as I have tried the same USB on another computer, which offers me both boot options.

Browsed through every menu item again and again, but couldn’t find anything of the sorts. The option just isn’t there. The only other, vaguely resembling the described one, was the ability to boot USB in Legacy mode, which was set to “Auto” now changed to “Enabled”, but with the same result (USB could still have only been booted as UEFI).

It’s an American Megatrends UEFI on ASUS K55A laptop.

Since we now know UEFI is the culprit, I should mention that mine is currently at version 406. As could be seen on the official ASUS website, there is one more update (407) which only improves the memory margin, as stated, so I haven’t flashed it in order to avoid further complications, but if you think it might help, wil give it a try (though I suspect they would document any big change in firmware, such as the option we are looking for).

It seems you have checked where you should check, yet found nothing to make it work in BIOS mode alias legacy mode. You could try again with legacy mode and secure boot disabled (and maybe disable some other setting, that might stop booting in legacy mode.

If still no luck, I suggest that you ask the ASUS help desk how to enable booting in legacy mode (use that terminology, because that is what they use in the UEFI/BIOS system).

If still no luck, you can try to upgrade the UEFI/BIOS system.

1 Like

I got a reply from ASUS telling me this particular model supports only UEFI BIOS. This is what apparently happens when you’re dependent on proprietary firmware. Wonder how Coreboot’s doing these days…

Thank you so much @sudodus for all your time, patience and valuable advice :pray: