Issues installing Budgie 18.04 - update microcode to 0x25 (or later)

Hey there!
I wanted to switch from UbuntuGNOME 16.04 to Budgie 18.04.
I have a ZOTAC ZBOX Magnus EN970 which is running on UbuntuGNOME since 16.04 and works perfectly fine.
I played around over the last years a lot and wanted to give Budgie a try. Since I don’t have any data on it that needs to be carried over, I thought clean new install is the best solution.

BUT I cannot get the installation to run.
I have used the wizard to create a bootable USB using the budgie 18.04 64bit iso available here.
The BIOS is set to “Win7 UEFI” (options: Legacy OS, Win8 UEFI, Win7 UEFI) mode, all other options are set to “Legacy”,(wherever I have the choice between UEFI, Legacy and Disabled - but I tried all possible combinations already), Secure Boot mode is STANDARD.
However, I always get the error MODSIGN: Couldn’t get UEFI db list when I boot the USB stick.

I also tried to switch to “Legacy OS” which gives my a long list, “console style” that obviously detects my Intenso USB stick in all details but then stops doing/responding to anything.

Any feedback is welcome on how to get this done, I am not a big Linux pro, but came to enjoy the OS over the last years a lot.

There are various suggestions here which you should try

hey, thanks - yes I saw that post earlier, too, that is what brought me to setteing the Secure Boot Mode to Standard in the first place.

But my issue is different than in the post you mentioned, as I CANNOT EVEN install budgie 18.04, I get this message when I want to run install from the live USB .

In the meantime I have updated my Ubuntu GNOME 16.04 to GNOME 18.04, which works fine as well.
But I want to run Budgie 18.04 and do a clean new install (so just switching to budgie DE is not what I want, thanks)

ok, this bugged me a lot so I investigated further - here is how far I came with this issue:
THIS article describes basically exactly my issue (exceptfor the installation the user tries to apply)

and the suggested solution there is to update the intel microcode.
I followed THIS instruction to do so and really got an update of my microcode applied successfully (2018-01-18 version):

Unfortunately I still see the very same behavior, when trying to install Ubuntu (Budgie) 18.04 clean from USB stick (again, the update within ubuntu worked fine, I am running Ubuntu 18.04 right now nut final goal is to get a new, clean installation and switch from formerly Ubuntu GNOME to Budgie).

On the intel website there is a newer microcode package available for download, it is from 2018-03-12, but when I run the apt install intel-microcode command now, it returns I am on the most current version (which is obviously not entirely true) - but I hesitate to follow the article from above for the manual microcode update since I am not very well experienced with all that copying and moving described there.

Any suggestions what I could test else?

Please can you report a new issue to launchpad: OpenID transaction in progress

tag the bug as bionic so that the kernel developers are aware.

not sure if I can capture the whole of the relations behind the curtain but the issue is solved for me.

  1. Updated BIOS for my Zotac EN1070K to latest version
  2. checked microcode used for updates (in my case, none after the BIOS update, before it showed a newer version was available)
  3. Disabled Secure Boot
  4. Used UEFI Compatible settings for booting

At this point the Live USB stick was booting already, but hung with a black screen
4. add “nomodeset” in grub console to Install Ubuntu Budgie to address NVIDIA driver issues

Good luck to everyone out thtere.

1 Like