Ubuntu Budgie 20.04.1 "no bootable device" after install

Ok, so I its been some time (10years) since I’ve done a install of Ubuntu and I tried making a bootable USB flash drive with Ubuntu Budgie 20.04.1 I liked the OS so much i thought why not erase my HDD with Windows 10 on it and to a clean install from inside Ubuntu Budgie 20.04.1 and everything went smoothly and yes just to touch base the initial bootup to the USB filecheck was good. But nevertheless after the clean wipe and install all done thru the Budgie OS once it was done I was instructed to restart and remove the installation medium which again it all went smoothly untill the restart where I was informed there is no device found. After all was said and done I loaded up the USB Budgie and found to my surprise the OS on the internal HDD of the laptop. Incase anyone has hardware questions ill enclose a picture of my specs


I guess something’s wrong with GRUB.

From your live-usb-session do a « boot-info »

sudo add-apt-repository -y ppa:yannubuntu/boot-repair && sudo apt update && sudo apt install -y  boot-info && boot-info

and paste here the link to report.

lsblke -fe7 -o +size

might help see your discs and partitions and mounting points.

So there was a Windows previously on that disc.
Maybe some SecureBoot to disable ?
Or setting bios to boot in bios/legacy mode instead of UEFI ?

i just tried to disable secure boot and see what would happen but i got the same message “no bootable device found”…

tried legacy mode as well no results

Seems there’s still a Windows Boot Manager on that disc.
Do you still need Windows on that machine ?

If Windows no longer needed, maybe easier to
⋅ from live-session, totally erase everything on that disc using gparted,
⋅ no partitioning, no formatting, just leave the whole thing as unallocated space,
⋅ then reinstall Ubuntu-Budgie, using default options and suggestions by the installer.
It should be enough.

Or use again the install line from second post and launch this time boot-repair instead of boot-info but here am less sure of what will happen because of the remaining Windows Boot Manager.
As mentioned by boot-info, boot-repair would do :

The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of
using the following options:        sda1/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s  use-standard-efi-file    

Final advice in case of suggested repair: ______________________________________

Please do not forget to make your UEFI firmware boot on the Ubuntu 20.04.1 LTS entry (sda1/efi/****/shim****.efi (**** will be updated in the final message) file) !

It’s the very last line that worries me a bit, not sure what it means.

Ok I had an idea the secure boot had a manual entry option so I found GRUBX64.efi file and added a short Ubuntu20.04.1LTS tag to it and I some how got to GNU GRUB 2.04 but when I try booting into Ubuntu I get a new error

Also tried “advanced option” got the following error :

Ok new update I changed something and I can’t seem to undo it and I’m back to square one again

Are these after you wiped out your entire disc and made a new installation ?
Or it’s the same install’ from first post ?
Or it’s the same install’ after boot-repair ?

Every post i make is in chronological order…

I’ve tried to replicate the GRUB load up but so far I’ve been unsuccessful.

There was this quote from the terminal post that i recognized from the bios.

The secure boot gave me an option to choose a .efi to boot to and the bios changed the boot to the GRUB. But since I tinkered with the bios again I can’t seem to get the bios to change the .efi
But even if i did get the Bios to load up that GRUB screen from before the system wasn’t allowing me to move forward past GRUB

When I get back home (I’m at work) I’ll make some screenshots of the bios so you can see what I’m seeing. Maybe then you’ll have a clearer picture of what I’m referencing above.

Ok, but it’s not an answer to :

I think it would be easier to start from zero, see :

1 Like

Ok so i wiped the entire disk with the live USB Budgie-Ubuntu installer, took me 10 hours.

From the wipe i installed budgie via the normal install method, choosing erase and install option.

After install is complete i restart laptop, ASUS logo appears and then “no bootable device” appears immediately after.