Fresh install - No boot. Assistance requested please

Basically just a small amount of experience with Linux. trying to get into it more.

I had UbuntuBudgie working but installed Ubuntu studio. It caused issues so I reinstalled Ubuntu Budgie from scratch again and this time I can not get it to boot. It appears grub was not installed during the install process. I’m using an older Bios style MB. The system is basically a 1366 board with a 6 core xeon cpu and a AMD RX580 8gb gpu. For this install I disconnected all drives accept a 250 GB pny900 ssd and the live usb I created from an iso. I really like UBudgie but I’m getting discouraged about this install snag. I tried 3 times now and of course the same result.
The last time I installed it, maybe two weeks ago, it just worked! Booted right into Ubuntu budgie, I don’t remember even engaging with grub at all. Clearly I’m missing something. I appreciate any advice.

Are you using the option to erase the disk before installing?

Yes. I’ve tried two of the erase and install options. The first top choice and the one with the advanced option. I did not select any advanced options.

Please use the something else option and take a photo using your phone with what you see and paste here.

I would expect the install should be on the /dev/sda1 partition with grub installed on /dev/sda

Thanks for helping me with this. Before your above request for a photo I had tried installing just Ubuntu to see if it would boot. It did NOT. So then I got your photo request and decided I needed to re-install UbuntuBudgie before I could take an accurate photo. At the conclusion, I expected boot to once again fail and I could then go through the install process selecting the “something else” option and take the pictures you requested. However, this time it booted as before with seemingly no grub involvement…at least that I could discern. I am uploading pictures I took using Gparted.

There is one 250 GB drive /dev/sdc and the flash drive /dev/sda. Pics follow…

The fact that it has installed and you can boot is great news!

I am a more than a little surprised to see your flash drive as /dev/sda … its normally /dev/sdb or later.

Also surprised to see the install is on /dev/sdc … i would have thought that would be /dev/sda

You mentioned you had but disabled/removed some drives. So maybe something in your setup was reassigning different drive ids?

Worth keeping an eye on this in the future. If you do have boot issues in the future this should help

It is a bit of a mystery why it would NOT boot and then decided it would. I reconnected the other drives in my system and used the “Disks” application to show the details of the other drives. I’m still unclear what bootloader is actually booting the Ubuntu Budgie when booted directly from it’s drive??? I see no reference to grub. The other drives contain either data or one of three MacOS versions that I keep on my system. I have managed to boot into opencore from my main Mac drive and then have an option within opencore to boot Ubuntu Budgie. That saves a step in rebooting between OSes.
Thanks again for your help. I will follow up on looking into that link to /Boot-Repair, especially given the fact I have no idea why my system now boots after 5 or so tries to make it happen.