Error getting after installation

Hi there,
I recently installed Ubuntu Budgie 20.04 lts on myy system. It was successfully installed but when I restarted after installing it showed “This is not the bootable drive, please insert bootable floppy and press any key to try again”. Please help me.
My system specs:
Cpu: Pentium dual core e5700@ 3ghz
Ram: 4gb
Gpu: Onboard
Mobo: intel dg41wv

Hey Guys please help


You will need to say a bit more about your installation. What options did you use to install?

Was this a dual boot? Did you use some sort of custom partitioning?

No it is clean installation and it has 4 partitions. I installed ubuntu in 1st partition with efi 512mb and swap area 4096mb

Did you specify that grub to be installed to /dev/sda?

Also did you remember to set the boot flag for the main partition (boot) ?

Yes I did that thing

If there isn’t anything else on that disk I would just do an automated entire disk install. It really does sound like you have done something wrong with your partitioning.

Ok I will try this thing but I have some important files in those partitions and have no other source for backup as of now. So let me check that thing.

I did it, again the same problem appears.


Is that motherboard from around 2007 to 2010?

I am just wondering if it allows 64bit grub installs. If it is expecting 32bit boot (it’s the sort of thing old motherboards expected) then you are a bit stuck since all 20.04 ubuntu based installs are now expecting full 64bit installs.

Yes it is fully 64bit and previous version of ubuntu worked fine and 20.04 version also worked fine. Now when I am installing this Budgie version this error appears up

The 20.04 installer for ubuntu and ubuntu budgie are identical. So this is very puzzling.

When you booted the usb did you leave the iso check running? Did it complete without errors?

Yes I checked for the disks and it didn’t show any errors

When do you see this ↓ right at start and before grub ( or Ubuntu logo ) is displayed ?

If yes then it sounds like bios only looks for a floppy drive to boot from.

Might be some settings to change in your bios, things like boot sequence / boot order / devices boot.

There you should specify on which order bios checks the « bootable » devices.

Generally firsts are removable ones ( floppy, usb, optical ) and last is the actual disk where system is installed on.

Often one can access bios settings by hitting [ esc ] or [ del ] or an [F#] key, depending on bios vendor, at very start.

Thank u for the solutions it got solved