Can't Boot UB 21.10 Bios Mode without using F10 and Select Drive

Unless I use F10 and Select, I get “no bootable disk” message from my BIOS. I’ve installed separate disks with other Op systems … no problems. (Ubuntu 20.04, Mint 20.1, Zorin 16, Fedora 35, etc). It seems UB install forces Uefi options. Not good. I need Bios mode or legacy mode. I have disabled Uefi in my bios.
The UB makes my disk install type GPF. I’ve tried to convert it back to MBR but I get lost with Grub installation issues. I’ve tried “Budgie Something Else” during installation but was not successful. I’ve tried “Disk-Repair” but to no avail. I like UB so any tips or help would be appreciated.
(Hardware is Intel Core 2 Quad)

hmm UbuntuHandbook | How to Install Ubuntu 21.10 or Ubuntu 21.04 from USB [Step by Step]

According to that link you have to use something else

"Click on the free space, then click “+”. In pop-up window, choose:

EFI: 250 MB, use as “EFI System Partition”
or BIOS-Boot: 1 MB, use as “Reserved BIOS boot area”


So choose the BIOS-Boot.

There was a change to Ubuntu in 20.10 that assumed EFI for installs and I’ve seen others with similar issues.

Ubuntu Budgie 20.04 is the same installer as Ubuntu 20.04 which you said was ok to install.

Thanks. I actually did that in Gparted before attempting to save my data. I’ll give your suggestion a try using a fresh install and see what happens. (Perhaps the installer code wants to be completely in charge.)

No Success. Symptoms remain the same. It still finds a “valid GPT” even though I created a root partition on top of it. I’ll do a security erase on the disk and try again.

Here’s some data:

bruce@UB-ssd:~$ sudo su
[sudo] password for bruce:
root@UB-ssd:/home/bruce# gdisk /dev/sda
GPT fdisk (gdisk) version 1.0.8

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT.

Command (? for help): ?
b back up GPT data to a file
c change a partition’s name
d delete a partition
i show detailed information on a partition
l list known partition types
n add a new partition
o create a new empty GUID partition table (GPT)
p print the partition table
q quit without saving changes
r recovery and transformation options (experts only)
s sort partitions
t change a partition’s type code
v verify diskv
w write table to disk and exit
x extra functionality (experts only)
? print this menu

Command (? for help): p
Disk /dev/sda: 234441648 sectors, 111.8 GiB
Model: ADATA SU655
Sector size (logical/physical): 512/512 bytes
Disk identifier (GUID): 8736BB2D-00F8-402B-979B-5AA58CC8DA24
Partition table holds up to 128 entries
Main partition table begins at sector 2 and ends at sector 33
First usable sector is 34, last usable sector is 234441614
Partitions will be aligned on 2048-sector boundaries
Total free space is 2925 sectors (1.4 MiB)

Number Start (sector) End (sector) Size Code Name
1 2048 4095 1024.0 KiB EF02
2 4096 234440703 111.8 GiB 8300

Command (? for help):
Command (? for help): i
Partition number (1-2): 1
Partition GUID code: 21686148-6449-6E6F-744E-656564454649 (BIOS boot partition)
Partition unique GUID: CB13D158-E287-45D7-9BB1-4DC3527C1B63
First sector: 2048 (at 1024.0 KiB)
Last sector: 4095 (at 2.0 MiB)
Partition size: 2048 sectors (1024.0 KiB)
Attribute flags: 0000000000000000
Partition name: ‘’

Command (? for help): i
Partition number (1-2): 2
Partition GUID code: 0FC63DAF-8483-4772-8E79-3D69D8477DE4 (Linux filesystem)
Partition unique GUID: 6FA6ED3A-4966-4528-BDB6-92F7F3449D26
First sector: 4096 (at 2.0 MiB)
Last sector: 234440703 (at 111.8 GiB)
Partition size: 234436608 sectors (111.8 GiB)
Attribute flags: 0000000000000000
Partition name: ‘’

Command (? for help):

There is something very similar at the following link. I tried setting the boot attribute but it didn’t help. This is part of the “expert” options in gdisk. I set the “legacy BIOS flag” in both partitions. No improvement.

Is it possible to mark the protective MBR of GPT Disk as bootable from Windows ? - The Syslinux Project -

I jump in just for a question :

is it now mandatory to have a bios_boot partition to install Ubuntu,

even if the system disk has an mbr/dos partition-table and the UEFI-bios is set to legacy mode ?

Which leads to this other question :

if I want to install 21.10 or 22.04 alongside my actual systems ( where actually no bios_boot and in UEFI-legacy-mode ) what are my options ?

I may understand why UEFI is given priority by modern installers but installers should not break what’s already installed.

Next, I tried “Disk-Repair” to straighten out the boot. … No improvement.

Next, I took the same hardware and drive and installed Ubuntu 21.10. … No improvement. Exactly the same symptoms using the BIOS mode install.

BTW: Ubuntu 20.04, Mint 20.1, Zorin 16, Fedora 35, and others all work fine!
OS: Ubuntu 21.10 x86_64
Kernel: 5.13.0-23-generic
Uptime: 11 mins
Packages: 1717 (dpkg), 8 (snap)
Shell: bash 5.1.8
Resolution: 1920x1080
DE: GNOME 40.5
WM: Mutter
WM Theme: Adwaita
Theme: Yaru [GTK2/3]
Icons: Yaru [GTK2/3]
Terminal: gnome-terminal
CPU: Intel Core 2 Quad Q9400 (4) @ 2.664GHz
GPU: Intel 4 Series Chipset
Memory: 905MiB / 7908MiB

Thx for confirming on ubuntu 21.10

Question? Why are you installing on bios mode when your computer is capable of uefi?

To my mind bios mode is for seriously old hardware where uefi is not an option.

I have over 30 disks that contain operating systems over the last 10 years. With a front loader, I can change the op-sys/drive in less than a minute. Uefi adds a complexity that I don’t want. Most operating systems from this decade still work fine. UbuntuBudgie has the best combination of features and simplicity that I have seen in years. I love it. I hope that with the help of the development group, we can solve this seemingly minor problem. Fossfreedom, thanks for your input. (I’ve been reading “It’s Foss” for years.) BTW, it tried to add this discourse to the Ubuntu feedback site but quickly got lost. They don’t seem to discuss installation problems.

ok - since you have tried and confirmed the issue is more general with all variants of 21.10 can I suggest the wider audience support forums - &

Hopefully the more general audience can find an answer for your setup.

Using gdisk, I found that the disk was still in GPT mode in spite of my changes. I then started over and using gparted created the following MBR disk table:

I then did a fresh install of Budgie 21.10 and chose “something else”. I had to bypass 5 error messages trying to convince me that EFI was missing. (I knew that!) The install went normally and the computer boots and works perfectly. Note: there is an option in gdisk to convert GPT to MBR but I couldn’t make it work.
I also left the problem on the AskUbuntu site but have not gotten any replies.

I next tried it on Ubuntu 21.10. Works fine. This MSDOS table can be much simpler: A 16MB boot partition and the rest an EXT4 root partition.

That doesn’t make sense - all ubiquity based flavours should behave the same.

Please file a bug report and state clearly what your setup is, what you have tried etc. Don’t link back to here since a launchpad bug report needs to be self contained.

ubuntu-bug ubiquity

To: fossfreedom, The following flavours ARE behaving the same: Ubunty 21.10, Bundgie 21.10, and unsupported 22.04. I have submitted launchpad bug report #1960141. Erich Eickmeyer has cancelled the bug report saying that it’s not a bug. He recommended that I go to the support tracker at