22.04 : unable to add printer ( which perfectly worked in 20.04 )

Hi,

The printer is a Ricoh Aficio mpc 3002 - drivers are ok, it helps Ricoh is a memeber of the Linux Foundation. Hear : it’s not a driver issue.

After upgrade from 20.04 to 22.04 ( 20.04 where that printer was ok ) I’ve noticed I was no longer able to do color prints ( whatever I set in printer options, it always came back to B&W ).

So I decided to remove the printer and « reinstall » it.

Budgie Control Center can find the printer but click on the Add button leaves to :
⋅ nothing ( add button just turns grey )
⋅ or an useless error message pops out « there was a problem, printer not installed ».

It’s been years I use those kinds of products from Ricoh knowing they work under Linux ( almost ) out of the box.

Any help welcome…

Sounds like this Q&A

The first answer refers to system-config-printer which you can run from a terminal.

The second answer (which isnt an answer confirms ricoh printer issues)

Third answer refers to a snap that i havent tried myself.

Note. I spotted a printing issue on IRC today on #ubuntu-desktop

It mentioned not being able to find a printer when the laptop is connected to the local network via wifi. But it worked just fine when the laptop was connected to the router via ethernet.

So worth checking that as well.

It’s at work, so only wired network.

The printer is seen, is found but is not added.

Thanks for these suggestions but to try any of these I should first be able to « add » my printer.

I’ll see tomorrow if system-config-printer can help about that.

Also, I had no choice in « searching for drivers » in the printer properties, only blank windows ( instead of https://i.stack.imgur.com/VnZDB.png ).

All these accessed through Budgie Control Center / Printers.
Wonder if
⋅ I have all the packages needed ;
⋅ if groups and users regarding « printing features » are correct ?

Maybe has there been changes on that matter between 20.04 and 22.04 ?

Whatever happens, it’s a quite big issue in the context of that machine… and of course I did not prepare any way to go back to 20.04 my stupid trust, lol.

Let’s try…

Printer is seen ( Aficio )

but I’m stuck here, looking for drivers although I have them downloaded and installed from Printer: Ricoh Aficio MP C3002 | OpenPrinting - The Linux Foundation

Obviously I don’t have a ricoh to test with… but I didnt need to download a PPD

when running system-config-printer I chose Server - New Printer

Then I choose the “Generic CUPS-BRF” - clicked the Forward button

I left the radio button at Select printer from database

I chose Ricoh → Forward

I then chose Ricoh Aficio MP C3002

There was multiple drivers to choose from - I chose the Cups+Gutenprint driver for this test → Forward

I changed the name and description and chose apply

Then I clicked on the printer - right click and chose properties - on the device URI I chose Change - chose AppSocket/HP JetDirect and entered the Host and Port number and clicked Apply. I suppose LPD/LPR Printer could also have been chosen.

This ↑ reminds what I used to do ago.

…as soon as I click the forward button, it launches « software » searching for a driver there, which fails.

Maybe I should uninstall gnome-software ?

[edit] why is gnome-software a dependency to ubuntu-budgie-desktop ? Is it safe to remove it after all ?

no you don’t have to uninstall gnome-software. It has to be a dependency because otherwise the Canonical ISO sausage factory would decide to install the snap-store instead of gnome-software deb. Ho hum.

I don’t know why your jammy fails - it works here just fine.

Maybe have a look in the journal log to see if any errors are reported about the failure

journalctl -ae --full

In red :

août 23 15:08:26 PROLIANT python3[672729]: io/hpmud/jd.c 772: invalid host
août 23 15:08:26 PROLIANT python3[672729]: io/hpmud/jd.c 731: invalid ip
août 23 15:08:26 PROLIANT hp-makeuri[672729]: hp-makeuri[672729]: error: Device not found
août 23 15:08:39 PROLIANT python3[672828]: io/hpmud/jd.c 94: unable to read device-id
août 23 15:08:39 PROLIANT python3[672828]: io/hpmud/jd.c 746: invalid ip 192.168.92.185
août 23 15:08:39 PROLIANT hp-makeuri[672828]: hp-makeuri[672828]: error: Device not found
(…)
août 23 21:15:23 PROLIANT systemd[1]: fwupd-refresh.service: Failed with result 'exit-code'.
août 23 21:15:23 PROLIANT systemd[1]: Failed to start Refresh fwupd metadata and update motd.

plus some errors regarding nouveau driver, nothing new.

I wonder : what are my best chances to reinstall 22.04 while keeping $HOMEs ?
Because when I try the same thing from the other installed system, it works as you describe ( but unable to print in colors, only B&W whatever set in printer driver. )

So one of my problems sits in the upgraded system only ( and not on the plainly installed one ).

Anyway I need that printer and its colors - it’s a terrible bug.
I’d better be reinstalling 20.04…

Thats effectively what the ISO repair option does.

So that Q&A is quite illuminating. It is basically a CUPS bug. Elsewhere in those answers various people recommend using the pdf driver. Others change a field in CUPS itself (instructions in one if the answers/comments). And the bug report states using lpadmin to set things.

Basically you will have to try to see what works best for your particular setup.

Seems that a fix is in preparation. You should at the very least report a bug against the CUPS package otherwise Canonical will not be aware of the issue. Linking with all the details of what you have tried, the github bug report etc will be very helpful to ensure successful resolution.

Is there a way to use the package cups-filters from 20.04 meanwhile ?

Pdf Driver → B&W ( thats what I used to use till now ).
The snap thing gutenprint → does not find my printer
Changes in CUPS → I’ve never used CUPS so far ( I mean not directly to my knowledge )

I’ll try things and gather my « process » and see what I can find and report on launchpad.

As usual, many thanks for sharing your knowledge and ideas !

the package would need to be rebuilt for 22.04 with a version that is slightly newer that the 22.04 cups-filter package otherwise the 22.04 version will try to keep reinstalling.

The alternative I suppose is to pin the package version - whether the 20.04 package will itself install without any dependency issues I dont know. You could try that by downloading the .deb from launchpad and installing the package - you might though get into dependency hell…

Already reported here :

and added :

which will probably get marked as duplicate.

These are for the black & white issue.

It seems my unability to add printer in 22.04 is another problem linked only to an upgraded installation.
I’ll try to « repair » system on that one.

N.B. i think the printer name for lpadmin is the shortname you chose for your printer when you set it up in system-config-printer. Use a name when you are setting up without spaces e.g. ricoh

Ok, I ended up screwing everything, leading to a plain re-installation of UBudgie 20.04 where printer works as expected.

I still have a working 22.04 installation beside where I’ll try to figure out how to « fix » the B&W issue.

The long story : actually I was not so incautious and I had some Timeshift snapshots, therefore I decided to « roll back in time » to a 3 weeks old snapshots. I’m here on a 22.04 « upgraded » some days ago from 20.04.

All seemed to go well, rebooted fine at first sight. lsb_release shows 20.04 focal.
Setting printer ok. Relief.
Then I noticed I had no network at all, no way to enable it anywhere, nmcli complaining about being unable to do something with netplan.
Digging a bit in dmesg and other places I found netplan expected some version of libc ( ≥ 2.34 ).
And indeed, on a 20.04 glibc is 2.31 not 2.34.

Now looking closer at the installed kernels : my ( now ) downgraded 20.04 ( from 22.04 using Timeshift ) is actually running a 5.15.0-46 kernel ! I must have done something wrong with Timeshift.
Ok let’s try to boot an older kernel ( a 5.13⋅× if remembered correctly ) and… exactly same complain about libc version. This is unexpected.

Remember, I do all these on a production machine at work, such a good idea of mine, lol.
I backup’ed hidden elements of my $HOME ; visible data are safe elsewhere.
But work context where doing 3~4 things in the same time made me later forget « how » I did that backup and I deleted it while doing something else totally unrelated. Happy me.
This is just an anecdote.

But there’s a real question here, behind : after first initial 20.04→22.04 upgrade attempt I was already surprised I had to « reconfigure » my network. See Upgrading from 20.04 to 22.04.1 → 2 bad surprises - #7 by fossfreedom and I have no memory of any question regarding network-manager during the process ( about samba, I remember and expected it. )
So is there maybe some extra caution to care about network while upgrading from 20.04→22.04 ?

Ok we’ll never know because here I myself built the worst conditions for upgrading, I flatly admit.

But guys in years it’s not the first time I ( try to ) upgrade a ×buntu ( and UbuntuBudgie ) and failures are more common than achievements in that area ( for me. ) That’s why I usually prefer the dual boot route… Still, am the only one to blame for doing it here in such a bad prepared and unorganized way !

But I wanted to share that story to let you know I did not give up, lol.


Oh, there’s another question : where is the « repair » option in ISO ?
All I found ( and this was my last shot ) was in « Do something else », re-write on / without formatting it which led me to an non bootable system with 2 warning messages :
⋅ one for grub ( I think ) being unable to find the / partition by its uuid ( uuid which actually had not changed ) and
⋅ one regarding casper missing.

This is when I decided to do a plain, clean reinstall. And very clean since I had lost the hidden elements from my previous $HOME.