32bit EFI bootloader?

Hello! I was wondering if support could be added for users with a 64bit CPU, but 32bit EFI (old MacBook)? I tried following a couple guides but didn’t have much luck. I think my Radeon graphics added a layer of complexity to the instructions I was following. I had to add a 32bit EFI to the install USB to get it to be detected at all and then launch with the graphics mode option in grub. It installed fine and all but I cant boot after. I’m not too keen to follow anyone’s instructions…Id prefer if support was baked in. I’d hate for an update to lock me out again.


How about using Parallels Desktop, install Budgie on it.
It worked for me using a 2012 Mac Mini, macOS 10.14, Parallels 16.

David WA9ONY :slightly_smiling_face:

I don’t recommend anyone using unofficial respins of Ubuntu Budgie.

parallels or other virtualisation software is one solution - but obviously not a native solution.

1 Like

I have posed the question about 32bit EFI.

There seems to be reluctance to consider including grub-efi-ia-32 as a package in the ISO.

Likely this is because the 99+% of computers installed with Ubuntu now are true 64bit rather than the hybrid - the risk of broken installs due to badly written EFI manufacturers implementation where the wrong decision on installing 32bit over 64bit is key here.

I have a cheap intel atom based laptop with a 32bit UEFI implementation. I have done the workaround of installing the 32bit grub into the ISO to boot and install back at 18.10 - and have upgraded through 19.04/19.10 & 20.04 without at any point things being broken with any minor or major update.

OK. I wonder if you could walk me through the steps to install the 32 bit boot loader on the HDD from the install USB? And how to make it boot in “safe graphics” mode too, because I needed that for it to start the installer.

I want to install this along side my OS X install, whereas previous attempts were a complete install.

ok - for my laptop its a bay-trail processor and I used these instructions https://medium.com/@realzedgoat/a-sorta-beginners-guide-to-installing-ubuntu-linux-on-32-bit-uefi-machines-d39b1d1961ec

The article references a github repo with a 32bit efi - I don’t know if that works for a Mac - you might as well try.

Ask Ubuntu has similar instructions - again the references to where to find a 32bit efi are similar to the article - https://askubuntu.com/questions/392719/32-bit-uefi-boot-support - either extract it from a debian ISO (in the first highest answer) - or download it from the linked website.

In 20.04 when you boot you should be offered in the boot GRUB an option to boot with safe-graphics - this will ensure “nomodeset” is added for you when booting/testing and installing.

I have never installed on OS X but it should (in theory) be the same as Windows where you select the option in the installer to be a side-by-side install.

Thanks for the reply. That is the guide I was following. It was all good up until this point…

linux /casper/vmlinuz.efi root=/dev/<partition>
initrd /casper/initrd.lz

It never rebooted after this. I need to somehow enable the safe graphics mode I think?
Also mine was different, I used tab completion but my paths didn’t show file extensions.

When you get the initial boot with the “Try Ubuntu” etc press e to edit

linux /casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---

EDIT - my hunch here is that nomodeset can be added in the same way as a normal kernel edit which would look like

linux /casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper nomodeset ---

i.e. You need to add “nomodeset” at the end of the line before the —

linux /casper/vmlinuz.efi root=/dev/<partition> nomodeset --- 

During the installation make sure you tick the option to install 3rd party stuff - I’m assuming you have nvidia graphics - this will ensure the nvidia graphics driver is installed for your card.

Thanks. So the trailing stuff when I press E I should keep? I will try that now, I’m going to start over.

My graphics are Radeon. I think thats why I need to boot in safe mode. I read something about the drivers are not included and cause boots to hang?

Right - when you’ve dropped to the grub terminal (pressing C) you enter the stuff as in the blog - but with the “nomodeset” addition to the linux line.

If this doesn’t work then you have a really weird computer that needs more kernel options which is something I can’t really help with other than pointing you to this https://wiki.ubuntu.com/Kernel/KernelBootParameters

OK. After pressing E I see

set gfxpayload=keep
linux /casper/vmlinuz file=/cdrom/presees/ubuntu-budgie\.seed quiet splash nomodeset ---
initrd /casper/initrd

Edit: It just boots into the live USB and not my install.

I used…

linux /casper/vmlinuz root=/dev/sda3 nomodeset ---
initrd /casper/initrd

This is in the live USB GParted…

OKAY Everyone, this has already been solved. I was granted access to the junk closet at work and there were 3 (THREE) mac pro 1,1 cheese graters! I plugged all the ram into a single machine (a whopping 13 GB) and lit up … Snow Leopard. I went on a Linux spree and installed MANY different OS on the multiple drives(again, three mac pro 1,1)

The mac pro 1,1 was indeed one of those weird Apple 64 bit CPU with the 32 bit EFI, and Matt Gadient solved it! The caveat I found was you had to burn the .iso to a DVD rather than the oh, so convenient USB. The hard part of this will be sourcing DVDs.

ANYWAYS: the link to Matt Gadient’s page.

I burned and installed Ubuntu Budgie, elementary, Solus, Ubuntu, Antergos (dating myself, I know) Linux Mint, all worked. He explains what he changed in the .iso to make it work, and suggests that you do it yourself, so you understand what is being done to the .iso rather than just trusting that it’s been done right.

1 Like