All the applications I install from the terminal have a very small

Any application I installed using sudo in terminal has such small text that it becomes practically unreadable is there a way to fix this???

Please can you give an example of an app you have installed, the install instructions you have used and the instruction you used to run the application.

What version of Ubuntu Budgie are you using?

Here is screenshot of my window (spotify and steam were installed via terminal):

The Steam window text look extraordinarily small. The Spotify one might look reasonable but it is actually miniature.

For installing Spotify i used:

snap install spotify

For Steam i used:

sudo add-apt-repository multiverse
sudo apt-get update
sudo apt-get install steam

My ubuntu budgie version is

Budgie 10.5.1

Is this a 4K display? Are you using fractional scaling? If you are using fractional scaling then what happens if you just use the 100%/200% etc?

I use 150% fractional scaling
Yes 4K
And using any other scaling just doesn’t seem to bother these applications I tried 125 and 100 and 200

These are bugs with the fractional scaling implementation that Canonical have made available that budgie inherits.

Not alot we can do here other than advise you to file a report to launchpad

ubuntu-bug libmutter-7-0

^^^ if you are on UB 20.10 or

ubuntu-bug libmutter-6-0

^^^ if you are on UB 20.04

Ok… if there is nothing that can be done…

Its highly likely that many apps cannot cope with fractional scaling - there is no set coded method to deal with fractional scales currently via GTK and possibly other toolsets. Behind the scenes GTK which many apps a built with only supports integer scaling i.e. 100%/200%

Canonical’s method is kind of a fudge trying to bypass this. If an app is scaling wrongly its probably interpreting that the display is either at 100% or 200% rather than 150% - there isnt a coded method that says “the screen is now 150%”.

Really this fractional scaling needs to be added to the GTK/mutter toolkit - I doubt this will happen with GTK+3/mutter since this is effectively now fixed without change. GTK+4 is being developed - maybe this has better fractional scaling - but of course, apps will then need to be compiled against GTK+4 and future versions of mutter which in itself is no trivial matter.

It’s not just 4K. Any screen with a high resolution and small diagonal like 13.3" laptops with >1920*1080 resolution have this issue. It’s quite a disappointment app developers don’t take this into account.

For Spotify specifically the solution is easy:




Exec=spotify %U



Exec=spotify --force-device-scale-factor=2.0 %U


For Zoom it’s also doable:

Go to $HOME/.config
Find and open the file zoomus.conf

One of the settings is ScaleFactor, set to 1 by default. Set this to 2, and next time you start the application it will have appropriate-sized visuals.

Please do read what I wrote. There isn’t anything an app developer can hang their hat on here - so don’t “blame” developers. There isn’t an obvious way to say “this is 150% scaling”. The toolkits available just don’t have this information available.

My mistake, I didn’t read everything and thought solutions like that of Spotify would work in general for other apps.

That worked…
Thank You…

1 Like