How scaling 4k monitor to 150% (not 200%!)?

Title… How scaling 4k monitor to 150% (not 200%!)?

For 19.04 and 19.10 fractional scaling is available as an experimental option:

In a terminal

gsettings set org.gnome.mutter experimental-features "['x11-randr-fractional-scaling']"

Then use Settings - Displays to set the scale 1, 1.25 etc.

Note the emphasis is EXPERIMENTAL. What is required are people who have 4K monitors to also resolve issues found through workarounds/code fixes etc. As I understand it, current budgie desktop developers don’t have 4K equipment and therefore cannot help resolve issues found.

1 Like

Also note that many libraries aren’t capable of handling other scaling (yet) then of type int (100%, 200% etc). Gdk.Window.get_scale_factor() explicitely is of type int:

1 Like

It didn’t work :frowning: … anyway, thanks so much for the reply. Now how do I revert the mentioned command in the terminal?

gsettings set org.gnome.mutter experimental-features "[]" should do the job (or: dconf reset /org/gnome/mutter/experimental-features)

Not sure if this may be helpful or not, but however Unity in this distro implements fractional scaling it works really well in VM without any lag. May be totally different underpinnings given it being a different DE but if they are similar then I wonder if a patch may be possibly drawn out of it?

Just to note while fractional scaling did not appear to impact my cpu usage or keyboard input it does severely cause mouse lag making the system unusable. I have not tried fractional scaling in very many other distros atm, but I plan to. I normally scale by 2x.

Totally different window manager. Budgie uses a window manager called Mutter. It is the same window manager as GNOME Shell.

Note that there is also a bug in Mutter (X11) for intermediate fractional values (125,150,175) on 4K screens where the GDM mouse cursor sticks frozen through your session, meaning you have your normal cursor and an irritating other cursor frozen somewhere on your screen on top of every window (even full screen).
It can disappear when toggling back and forth from n x 100 values, but it might not as well.

In Gnome, a half working way to solve it is to comment out WaylandEnable=true (or set it to false) in /etc/gdm/custom.conf. But since Budgie uses Light DM, I’m not sure how and if it would work since wayland might already be disabled.

I’m not familiar with the bug in question. Fractional scaling works in Wayland for GNOME Shell. It currently does not work in X11. Canonical have added a proposed X11 patch for fractional scaling just for Ubuntu and we inherit that through Ubuntu Budgie. They have been gradually refining this patch over the last few months.