Android Device Are Not Connecting Via USB

I have tried connect my Android Phone to it but it does not shows anything.
Also tried Another Androids too.

Hi, couple of questions…

  • which version of Android?

  • what type of USB connector?

  • what kind of connection/feature are you trying to use?

I all because I’ll try to replicate. One thing to note, USB c I have found depends on the cables drastically. Not all cables are equal. while the standard is supposed to be able to carry data, power and video, I have found that sometimes certain features work with certain cables. and the reason I am asking about the feature is so that I can try to replicate your specific use case and have a target for success or failure.

Thank you!

How are you connecting phone to the PC? Have you tried to connect it with storage mode enabled on the phone?

I am running Android 8.1 On Mi A1
Using USB C to connect as a MTP
But after connecting the device to laptop it doesn’t display anything about connected device nither does the Android shows any options of UsB configuration.
I have tried Another samsung device too but same goes there.

Before this i i used the ubuntu basic and there the samsung device were displaying perfectecly.

Thanks !

That is the problem i don’t have any options to choose.
The Android doesn’t shows anything.
Nither does the debugging options does anything.