App volumes keep returning to 46% (Budgie 24.04) with USB audio


Changes to individual volumes keep returning to 46%, whenever an application is closed and reopened. Any changes are not persistent. It is independent of master volume. It does not seem to be a problem on the default Ubuntu 24.04 session.

Any ideas?

pulsemixer --list-sinks
Sink input: ID: sink-input-308, Name: speech-dispatcher-dummy, Mute: 0, Channels: 1, Volumes: [‘46%’]
Sink input: ID: sink-input-747, Name: VLC media player (LibVLC 3.0.20), Mute: 0, Channels: 2, Volumes: [‘46%’, ‘46%’]
Sink input: ID: sink-input-778, Name: Chromium, Mute: 0, Channels: 2, Volumes: [‘46%’, ‘46%’]

Thanks, L

Are you using the same user account to login to both gnome-shell and budgie?

What happens if you create another user account specific to budgie?

It still happens with a new account used only on Budgie, but good suggestion.

I have noticed it is happening with USB speakers, and not with internal speakers. Budgie session is affected, but not Gnome.

pulsemixer -l

Sink: ID: sink-48, Name: Built-in Audio Analog Stereo, Mute: 0, Channels: 2, Volumes: [‘80%’, ‘80%’]
Sink: ID: sink-50, Name: USB Audio Analog Stereo, Mute: 0, Channels: 2, Volumes: [‘80%’, ‘79%’], Default
Source: ID: source-48, Name: Monitor of Built-in Audio Analog Stereo, Mute: 0, Channels: 2, Volumes: [‘100%’, ‘100%’], Default
Source: ID: source-49, Name: Built-in Audio Analog Stereo, Mute: 0, Channels: 2, Volumes: [‘100%’, ‘100%’]
Source: ID: source-50, Name: Monitor of USB Audio Analog Stereo, Mute: 0, Channels: 2, Volumes: [‘100%’, ‘100%’]

inxi -SA
Host: user-HP-EliteBook-x360-830-G6 Kernel: 6.8.0-31-generic arch: x86_64
bits: 64
Desktop: Budgie v: 10.9.1 Distro: Ubuntu Budgie 24.04 LTS (Noble Numbat)
Device-1: Intel Cannon Point-LP High Definition Audio driver: snd_hda_intel
Device-2: Princeton USB Audio driver: hid-generic,snd-usb-audio,usbhid
type: USB
API: ALSA v: k6.8.0-31-generic status: kernel-api
Server-1: PipeWire v: 1.0.5 status: active

cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH|
HDA Intel PCH at 0x404a108000 irq 177
1 [Audio ]: USB-Audio - USB Audio
USB Audio at usb-0000:00:14.0-2, full speed|

I don’t have usb speakers to test with.

Closest I have are usb headphones. running goodvibes volume remains the same starting, stopping, closing, plugging in the headphones and starting goodvibes again.

So I still think this is more likely to be due to something conflicting between your gnome install and budgie install

I downloaded budgie 24.04 iso and booted from USB, but still the same.

Animated .gif below for illustration. mpv and chromium default to 46%, but firefox to 100%, for some reason.


I am trying to set the default individual application volume as a workaround. If I could change it from 0.46 to 1.0, I would find it enough to manage with master volume.

Setting ~/.config/wireplumber/wireplumber.conf.d/default-vol.conf, as suggested here, made no difference:

wireplumber.settings = {
  device.routes.default-sink-volume = 1.0

To gain use of wpctl settings subcommand, I also tried installing wireplumber 0.5.2 from debian experimental, but it also had no effect:

wpctl settings device.routes.default-sink-volume 1.0,

I don’t know if this is the right command though. I asked on pipewire IRC, but I got no response.

I think the correct setting is this one. I confused sinks and streams:

- Name:
  Desc: The default volume for playback nodes
  Type: Float
  Default: 1.0  [Min: 0.0, Max: 1.0]
  Value: 1.0

I don’t know why wireplumber ignores it and sets streams to 0.46:

wpctl get-volume 81
Volume: 0.46

wpctl get-volume 84
Volume: 0.46

wpctl get-volume 88
Volume: 0.46

Bug report filed here:

1 Like