Budgie control center sound settings doesn't recognize audio output

When using my front panel audio port, the sound settings panel just shows blank for the audio output device, the test popup shows “Testing(Null)”.

The output is correctly recognized by the pulse audio control app, and I can hear sound. I can also change the volume fine with the “status indicator?” applet as well as the slider in the raven menu.

However, if I change the audio output to “HDMI/DisplayPort GA104 High Definition Audio Controller” (not sure what this is), then I no longer have the ability to change back to the blank option corresponds to my front audio, until I go into pulse audio and disable the GA104 output there. I have this output “locked” as off in pulse audio, but selecting it in the budgie sound settings appears to override that.


please can you try the following from upstream to see if it has been fixed. This will allow us to narrow down the issue:

sudo add-apt-repository ppa:ubuntubudgie-dev/budgie-desktop-test
sudo apt update
sudo apt install budgie-control-center

Logout and login and try budgie-control-center again.

after testing please purge the ppa:

sudo ppa-purge ppa:ubuntubudgie-dev/budgie-desktop-test

Now my control center doesn’t launch lol. Nothing appears and a bit later I get the “Do you want to report a system problem?” popup.

(budgie-control-center:4608): GLib-GIO-ERROR **: 10:36:59.324: Settings schema ‘org.buddiesofbudgie.ControlCenter’ does not contain a key named ‘window-state’
Trace/breakpoint trap (core dumped)

ah - you also need to install the budgie-control-center-data package as well

Updating the control center did not fix the issue or change anything.

Go to the terminal and type alsamixer. Try to select audio input from there and then try to see if you can change it from there.

This therefore is a new unknown issue specific to your hardware.

To resolve will need someone with the same hardware to dig into the code and find out what is going on.

ok thanks, fwiw alsamixer and pavucontrol show the output fine, its just the control center than doesnt.