[bug] Dummy Output sound issue after latest update from 20.04.1

This morning I updated my laptop (20.04.1), Software Updater listed Firefox, LibreOffice and Ubuntu Budgie Base.

After a reboot, my sound output device is only a dummy, no other option available:

I tried lot’s of suggestions online, discovered it was a common issue in the past.
I have an AMD Ryzen 4800U laptop with I believe Realtek audio, not Intel.

Nothing I tried solved the issue. So I used TimeShift (phew!!) to go back to last week (4nov).
This solved it for me. I then created a backup of /etc/modprobe.d/alsa-base.conf and /etc/modprobe.d/blacklist.conf, performed the update, rebooted, again had the Dummy Output issue, copied those two backupped files to /etc/modprobe.d, rebooted: still had the Dummy Output issue :frowning:

For now I restored with TimeShift again and I will not perform an update. Please let me know what information I can gather to figure out the root cause.

See if it’s a kernel issue … i.e press and hold shift on boot to display grub and select the advanced options. Choose an earlier kernel

I tried 5.4 (something .42 or .52) and 5.8.18 (which I need for this machine as it is Ryzen 4000). No difference.
I don’t see related errors in boot.log or dmesg after a boot.

Also tried updating after unchecking these two items:

Still got Dummy Output.

What is the package list that is going to be installed to break your sound i.e.

sudo apt update
sudo apt upgrade

Dont press y to accept the upgrade … just need to see the list of packages. Maybe this will give an indication of possible areas to concentrate on.

I wanted to remove all the libreoffice items as they are not relevant but to prevent copy paste errors, this is the raw version

The following packages were automatically installed and are no longer required:
  intel-microcode iucode-tool
Use 'sudo apt autoremove' to remove them.
The following packages will be upgraded:
  accountsservice alsa-utils appimagelauncher apport apport-gtk chromium-codecs-ffmpeg-extra distro-info-data firefox firefox-locale-en fonts-opensymbol gir1.2-gweather-3.0 gnome-control-center
  gnome-control-center-data gnome-control-center-faces libaccountsservice0 libasound2 libasound2-data libatopology2 libgweather-3-16 libgweather-common libjuh-java libjurt-java liblibreoffice-java libnetplan0
  libnss-systemd libpam-systemd libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-gnome libreoffice-gtk3 libreoffice-help-common libreoffice-help-en-us
  libreoffice-help-nl libreoffice-impress libreoffice-l10n-nl libreoffice-math libreoffice-ogltrans libreoffice-pdfimport libreoffice-style-colibre libreoffice-style-elementary libreoffice-style-tango
  libreoffice-style-yaru libreoffice-writer libridl-java libsmbclient libsystemd0 libudev1 libuno-cppu3 libuno-cppuhelpergcc3-3 libuno-purpenvhelpergcc3-3 libuno-sal3 libuno-salhelpergcc3-3 libunoloader-java
  libwbclient0 netplan.io python3-apport python3-cryptography python3-distupgrade python3-problem-report python3-uno samba-libs spice-vdagent syncthing systemd systemd-sysv systemd-timesyncd tzdata
  ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk udev uno-libs-private ure zlib1g
76 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/188 MB of archives.
After this operation, 977 kB of additional disk space will be used.

alsa-utils gnome-control-center libasound2 libasound2-data libnss-systemd libpam-systemd libsystemd0 libudev1 systemd systemd-sysv

Those are the likely candidates … basically systemd or the alsa packages. Probably the latter.

It’s worth just test installing gnome-control-center first. Then install each package in turn until you find the culprit. You will need to reboot between each package install.

Losing sound is not so rare in Ubuntu.

sudo apt install --reinstall alsa-base pulseaudio


sudo update-initramfs -v -u -k all

might help.

losing sound happened to me.
i was running mint.
and then ubuntu budgie.
happened in both.
i finally hooked up my monitor through hdmi, and it sees my graphics card output.
my monitor has an audio jack for my speakers.
so i’m good.
it’s not uncommon as stated and as i found out.
just glad for me my workaround worked.

I want to do that, but after installing gnome-control-center, nothing appears in my App overview. When I launch gnome-control-center from console window, it just opens Settings? And there is no new item in Settings…

Thanks I will try that but first want to figure out which package is the culprit here.

gnome-control-center is settings.

want to figure out which package is the culprit here
when sound does not work

aplay -l 


pactl list

see ( french ) https://forum.ubuntu-fr.org/viewtopic.php?id=1988398

lspci | grep [Aa]udio && lsusb | grep [Aa]udio

to identify audio device

Yeah I totally misread his message as gnome-control-center is just one of them to test. I have now reduced it to being one (or more) of these:
alsa-utils libasound2 libasound2-data

The rest installed fine and no issues after reboot. Will continue testing these three.

Great news.

Once found, please report this to launchpad via

ubuntu-bug packagename

Afterwards you can use synaptic to pin the previous version of the package so that you can continue updating as normal but not upgrade the problem package until Canonical can issue a new release.

And the workaround for now:

  1. install the specific previous versions over the updated ones.
  2. pin the packages : sudo apt-mark hold libasound2 libasound2-data

I didn’t know about the apt-mark hold command. Or how to install specific versions with aptname=versionnumber. Learning a lot via this Discourse. Thanks!

Offtopic, but what this tool does:

Is kind of amazing! I haven’t installed it yet, but it seems to be ideal for most people, in combination with TImeShift. I prefer ext4 because copying files and random read/writes are much faster compared to BTRFS. Until that changes, I will probably not use that autosnap tool, seems a bit much to create snapshots with rsync all the time (TimeShift-rsync once a week is enough for now). But still a very cool idea that he has developed.

Interesting. Now that you have discovered it’s an alsa-lib issue I spotted this in this list of issues.

Is it your issue? https://bugs.launchpad.net/ubuntu/+source/alsa-lib/+bug/1901922

Well that is good news. I suppose a fix will be available soon.

I just noticed I have this issue with both the Intel based PC and this AMD Ryzen laptop, both are on Ubuntu 20.04.1: