Audio not detected (Salida ficticia / dummy output) on 20.04.1 LTS

Hi, well, I tried to install realtek-linux-audiopack-5.01 downloaded from MSI site for my H370-GAMING-PLUS pc

did some extra install, I guess alsa-utils because I read somewhere that this would install alsaconf because I was missing in the installation process

well, It didn’t install anything and also remove all previous configuration settings

also read that I could do:

sudo apt-get install --reinstall linux-image-extra-$(uname -r)

but I got this error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-image-extra-5.4.0-42-generic
E: Couldn't find any package by glob 'linux-image-extra-5.4.0-42-generic'
E: Couldn't find any package by regex 'linux-image-extra-5.4.0-42-generic'

any ideas on what I should do to get the sound configuration back ?

edited: 18-08-2020
I tried

sudo apt --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-uname -r linux-modules-uname -r libasound2

with no sucess at all

the first one is the one I should be using

00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
	    DeviceName: Onboard - Sound
	    Subsystem: Micro-Star International Co., Ltd. [MSI] Cannon Lake PCH cAVS
	    Flags: bus master, fast devsel, latency 32, IRQ 11
	    Memory at a3230000 (64-bit, non-prefetchable) [size=16K]
	    Memory at a3100000 (64-bit, non-prefetchable) [size=1M]
	    Capabilities: <access denied>
	    Kernel modules: snd_sof_pci

01:00.1 Audio device: NVIDIA Corporation Device 10fa (rev a1)
	     Subsystem: Micro-Star International Co., Ltd. [MSI] Device 8d92
	     Flags: bus master, fast devsel, latency 0, IRQ 10
	     Memory at a3080000 (32-bit, non-prefetchable) [size=16K]
	     Capabilities: <access denied>

I’m a little lost with this topic. Are you saying sound has never worked? Or it broke when you installed some-sort of driver?

If it has never worked then yes this is a bug and should be reported to launchpad

ubuntu-bug linux

e.g. this is the sort of bug report with the detail that is required https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1864871

It broke when I tried to install the new driver

If you boot with the previous kernel does the sound work?

plis, show me how to boot with the one before and I will try tonight

thanks in advance :slight_smile:

okey dokey.

Press and hold the shift key as soon as you start the computer. That should display the Grub screen.

If that doesnt work - pressing the Escape key repeatedly usually works as well.

Then on the Grub screen choose the Advanced options - you should see a list of kernels (latest is first). Choose the next kernel with the lower version number (not the recovery kernel) with the arrow keys. Press Enter to boot with that kernel.

1 Like

there where to more kernel configurations 42 and 26, none of them enabled my audio drivers

@fossfreedom didn’t work

I realize I have to audios, but I guess I only should have one onboard sound card ( Device-1 )

❯ lspci
00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 0d)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 0d)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:17.0 SATA controller: Intel Corporation Cannon Lake PCH SATA AHCI Controller (rev 10)
00:1f.0 ISA bridge: Intel Corporation H370 Chipset LPC/eSPI Controller (rev 10)
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-V (rev 10)
01:00.0 VGA compatible controller: NVIDIA Corporation TU117 [GeForce GTX 1650] (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 10fa (rev a1)
❯ inxi -SMA
System:    Host: home Kernel: 5.4.0-42-generic x86_64 bits: 64 Desktop: Budgie 10.5.1 Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Machine:   Type: Desktop Mobo: Micro-Star model: H370 GAMING PLUS (MS-7B22) v: 2.0 serial: <superuser/root required> 
           UEFI: American Megatrends v: 1.40 date: 07/19/2018 
Audio:     Device-1: Intel Cannon Lake PCH cAVS driver: N/A 
           Device-2: NVIDIA driver: N/A 
❯

To be honest, I dont know what config files that driver has updated.

Unless it can be worked out what it touches then it’s kind of difficult to advise further.

Hardware config files are spread out all over the file system. Some can be reinstalled with a package. Others that are installed in /etc are much harder to reverse

I get it

I would be too much if I post the script installer here ?

Sure. Use paste.ubuntu.com and paste the link

If the script begins to compile stuff and/or navigates down to other make files in sub folders then it becomes very very difficult to work out unless you are familiar with the project

great!

the unusual path to copy the file in the how-to says
1-3. Specify a new destination folder for saving.
It is recommended that you may create a new folder from
/usr/local/src/audio to save them. If you not find the
audio folder, you may need to create a new folder “audio”
by press “Create Folder” button.

the install script is here

Try

sudo apt install --reinstall libasound2 libasound2-data libasound2-plugins alsa-base alsa-ucm-conf alsa-topology-conf  alsa-utils

Then reboot but to an older kernel

1 Like

hell yeah!!!

rebooted with 5.4.0-40 and I got sound with HDMI and analog headphones!!!

GREAT!

but,

  1. how do it set this kernel to be loaded by default
  2. or, what next steps to do ?

suggest just boot with the old one for now.

There is a new kernel coming in the next few days - so look out for that in your updates.

Then you’ll be able to boot normally with that.

1 Like

ok, thank man, you save my month!

been two weeks for this my-mistake