Home Store Blog

Unable to change default device of the volume slider app in the taskbar


#1

Hi everyone,
As title says, unfortunately when I reboot my pc the device of the volume slider keeps resetting.
Is there a way to make it default? I tried looking in default apps but sound is not listed.
All help is appreciated


#2

My first guess would be… Go to terminal, type in “alsamixer” and set it there, otherwise, no real clue.


#3

I tried a solution related to alsa, but it mostly disabled my sound altogether, but thanks for your help!

To add more information to my post, the sound output is set correctly by default (and works), it’s just the volume slider to change volume that cannot be set to a default.


#4

Are you using dedicated sound card or integrated one and if so what model?


#5

Integrated one
Intel HD Audio controller
82801JI (ICH10 Family) ALC889


#6

Try to install pavucontrol and see if it fixes the problem.


#7

I installed pavucontrol and changed the green checkmark in ‘Output Devices’ to the device I want to set as default (While doing that I noticed it also changed the selection of the device in the volume slider so it confirms I chose the right one) but unfortunately when I reboot it doesn’t keep it as default for both app


#8

What happens when you edit ~/.config/pulse/daemon.conf and add the following:
flat-volumes = no


#9

I added the command (flat-volumes = no) in the file with sudo nano ~/.config/pulse/daemon.conf , set the device to the one I wanted in the volume controller and rebooted my pc but unfortunately it still doesn’t keep it.
Thanks for your help still, I appreciate it!


#10

A dirty fix would be a startup script, but is not really in the spirit of actual problem solving. You would still be off-sound until it’s called and needs to be added per user probably.


#11

I was thinking, maybe I can disable the device as sound output and it would stop choosing it all together? Since its just a mic, it shouldn’t even be counted as speakers