Cannot change themes after hard reset

Hi,

I am using Ubuntu Budgie 20.04. After a hard reset, I have no longer been able to set dark mode or change window themes. I cannot change from light mode or use anything except what I suppose is the default theme.

I created a new user profile which was also affected.

I also tried reinstalling the below, with no effect:

budgie-core_10.5.1-6ubuntu0.2
budgie-desktop_10.5.1-6ubuntu0.2
budgie-desktop-environment_0.13.7
budgie-extras-common_1.0.2-0ubuntu1
budgie-extras-daemon_1.0.2-0ubuntu1
libbudgie-plugin0_10.5.1-6ubuntu0.2
libbudgie-private0_10.5.1-6ubuntu0.2
libbudgietheme0_10.5.1-6ubuntu0.2
ubuntu-budgie-themes_0.12.3

Changing to dark mode using dconf-editor also had no effect.


EDIT: I also tried a hack approach (which I am open to):

I attempted to force Pocillo-dark-slim as the default theme, by removing all the others:

sudo mkdir /usr/share/themes-backup && mv /usr/share/themes/* /usr/share/themes-backup && mv usr/share/themes-backup/Pocillo-dark-slim /usr/share/themes

I don’t know if this would have worked anyway, and if it had created a problem, I would have booted into run level 3 and restored the themes on the command line, or used a live cd.

Strangely, this had no effect whatsoever.


Would anyone be able to help?

Thank you,

L

Hi and welcome!

Please can you explain what you mean by a “hard reset”.

Also what is “light mode”?

So are you changing the theme in budgie-desktop settings? What themes are you seeing listed and what happens when you choose another theme that is listed?

When you say you have create a new user profile do you mean you have created a brand new account and logged into that?

Hi,

Hard reset : restarted the computer using the power button. A process was using all the RAM and I needed the computer urgently.

By “light” mode (i.e. theme, sorry), I just meant, not “dark theme”.

I changed the theme in budgie-desktop-settings.

Nothing happens at all when I change the widget theme, the icon theme, or use the dark theme toggle. Logging out and in, or restarting, seems to make no difference.

The themes it shows as listed currently are (quite a few from other desktop environments):

Albatross, Ant, Arc, Arc-dark, Arc-darker, Artwiz-boxed, Bear2, Blackbird,Bluebird,Bright, Daloa, Default, Default-hdpi, Default-xhdpi, Evopop, Evopop-Azure, Greybird (lots of them), Hooli, Kokodi, Materia (lots of them), Mikachu, Moheli, Natura, Nightmare, Onyx, Onyx-citrus, Pocillo, Pocillo-dark, Pocillo-dark-slim, Pocillo-light-slim, Pocillo-light, Pocillo-slim, Qogir, Qogir-budgie, Qogir-budgie-dark, Qogir-budgie-light, Retro, Smoke, Syscrash, Yaru, Yaru-dark.

By creating a new user profile, I made a new account, restarted and logged in to it. The desktop settings were of course default, but with the same issue.

This all seems to be new behaviour, which happened immediately after the restart I described. I have haven’t changed the budgie installation or settings.

Thanks very much for the reply.

LS

*I have memories of occasional weird things like this from using Windows 98, which seemed to crash lots, and had to be restarted using the power button.

Sounds like your gsettings package / packages are corrupted somehow.

Suggest try some of the answers here My dconf/gsettings installation is broken. How can I fix it without Ubuntu reinstall? - Ask Ubuntu

Maybe something easier to check :

find ~ ! -user $USER

( copy paste this command as is )
In normal circumstances, that command should output nothing, and it’s ok.

Else it will list files and folders that no longer belong to you and should be reclaimed.

Do you happen to play with sudo commands ?

Or, bad, do you happen to launch « graphical » applications from terminal but with sudo ?
Bad things like sudo nemo or sudo gedit or sudo any_windowed_app ?

Could it be that you have multiple desktop environments installed side by side under the same user? Although this should theoretically be possible, users on Ubuntu forums advise against it, as it can often lead to conflicts if you don’t know exactly what you are doing.

No fixes so far, unfortunately. I may just do a reinstall.

One question:

When I completely delete the contents of /usr/share/themes, Budgie still boots the default theme.

Why does this happen? Is it also installed somewhere else? I was expecting the desktop environment to fail to boot.

You may have locally installed themes either

~/.themes

Or

~/.local/shares/themes

Hi, they have all been deleted (or moved elsewhere temporarily):

ls: cannot access ‘/home/user/.themes’: No such file or directory
ls: cannot access ‘/usr/share/themes’: No such file or directory
ls: cannot access ‘/home/user/.local/share/themes’: No such file or directory

Themes aren’t installed anywhere else …

Please output from command suggested here ?

ls /usr/share/themes/

should answer something. Unless you deleted that « themes » folder from your system - which you should not do.

How comfortable are you with rights, permissions and sudo usage ?
And as @Piscatorius suggested, do you have other desktop environments installed on your system ( aside from Budgie ) ?

Would you mind showing

history | grep -Ei "sudo|themes"

Hi,

Thanks for the replies.

I do have other desktop environments installed, but without problems until now.

I agree deleting /usr/share/themes would be bad. It was moved to /usr/share/themes_backup , to see what would happen. I expected a boot failure, which could be fixed easily by just moving it back, after booting into run level 3 (command line) or using a live CD. This did not happen though.

I did this so that, if I deleted all themes, and then later moved only one theme back to /usr/share/themes, I could force a change of the default theme to what I want, seeing as I cannot change it now.

I am comfortable with rights, permissions and sudo. This command brings back no results:

find ~ ! -user $USER

I have a feeling this issue will be unsolved, and is perhaps from rebooting with the power switch, which I have not heard to be good for your computer, though this is beyond my knowledge.

I would like to know how Budgie and Gnome can boot with no themes installed, though. Perhaps there is some feature of Gnome (and Budgie, as it is based on Gnome?) to store the default theme somewhere. I will report back any findings.

On an Ubuntu based system, cohabitation of many DE without problems ( sooner or later ) sounds like a miracle :slight_smile:

Do you have one user dedicated per DE ?

Still it’s also very unexpected you wouldn’t find :
ls -la ~/.themes
or
ls -la ~/.local/share/themes
if you installed themes user-side.
Those folders may not exist on a fresh installation though. ( Or a recently created user-session ).
But
ls -la /usr/share/themes/
should answer something.

Outputs of suggested commands are not an option if you’re looking for help : it’s the only way for us at the other side of the world to « see » what you « see ».

What is or are the other DE installed on your system ?
ls /usr/share/xsessions/

Maybe look for files named index.theme to find out where they’re stored ?

Yes, as an experiment, I deleted them!

It was just to see if, by not deleting just one, I could force it to be default.

I reinstalled them again, but no success.

user@user-pc:~$ ls -la /usr/share/themes/
total 88
drwxr-xr-x 18 root root 4096 Jul 5 12:17 .
drwxr-xr-x 526 root root 20480 Jul 5 12:17 …
drwxr-xr-x 4 root root 4096 Jul 2 17:45 Adwaita
drwxr-xr-x 4 root root 4096 Jul 2 17:45 Adwaita-dark
drwxr-xr-x 4 root root 4096 Jul 2 17:44 Default
drwxr-xr-x 4 root root 4096 Jul 2 17:44 Emacs
drwxr-xr-x 6 root root 4096 Jul 2 17:45 Pocillo
drwxr-xr-x 6 root root 4096 Jul 2 17:45 Pocillo-dark
drwxr-xr-x 6 root root 4096 Jul 2 17:45 Pocillo-dark-slim
drwxr-xr-x 6 root root 4096 Jul 2 17:45 Pocillo-light
drwxr-xr-x 6 root root 4096 Jul 2 17:45 Pocillo-light-slim
drwxr-xr-x 6 root root 4096 Jul 2 17:45 Pocillo-slim
drwxr-xr-x 10 root root 4096 Jul 2 17:45 QogirBudgie
drwxr-xr-x 10 root root 4096 Jul 2 17:45 QogirBudgie-dark
drwxr-xr-x 10 root root 4096 Jul 2 17:45 QogirBudgie-light
drwxr-xr-x 3 root root 4096 Jul 2 17:44 Raleigh
drwxr-xr-x 3 root root 4096 Jul 3 18:49 Yaru
drwxr-xr-x 3 root root 4096 Jul 3 18:49 Yaru-dark

Thanks for the reply

I tried the following with no changes:

apt-get install --reinstall dconf-cli dconf-editor dconf-editor dconf-gsettings-backend dconf-service libdconf1

I also tried using dconf-editor. I cannot see an option to change the theme.

I can only see the option for dark mode under com.solus-project.budgie-panel

How can I set the desktop theme using dconf-editor (or gsettings), instead of budgie-desktop-settings?

Thanks again for replying

To be honest … I would now backup my home folder and do a clean install. Something is very wrong - what? … I don’t know but its just quicker to go for a brand new and safe installation.

↑ those look like a very normal and default situation on a Budgie Ubuntu.

So now I wonder what is the initial problem ?

Still… playing with many DE « under » Ubuntu and potentially under only one user will lead to confusion : some DE will try to over write their own settings in ( undesired ) common files in ~/.* and even sometimes system side in /etc/…

Hi,

It looks like gnome xsettings daemon was not starting. I also asked at the Gnome forum when I was getting stuck, where it was mentioned about the xsettings manager. (Is the default desktop theme backed up outside /usr/share/themes? - #4 by matthiasc - Desktop - GNOME Discourse)

Adding /usr/libexec/gsd-xsettings to the autostart programmes fixed the issue, although I am not sure how it came to be broken.

Thanks,

L