Date Time desktop applet : no longer shows month in date?


UB 18.04 here. There have been updates regarding many applets recently and…

…ShowTime ( date time indicator on desktop ) is now quite different : new settings, new fonts, and no longer shows month in date.
Only name of the day and its number. Intended ? Or an option I have missed ?
French language here if it matters.

Hmmm, not sure. There has been one version with an issue on the date format, not sure if it possibly landed one way or another in 18.04. Do you have backports enabled? Need to get back to you on this. You can set your own date format in the new showtime btw from gsettings (dconf editor), according to this string formatting: By default, the month should show though.

Could you add the output from locale date_fmt ?

I can’t see where to set my own date format ?

As you can see I have set a personal date format in calendar applet in top panel.

( and french translation for settings in ShowTime applet are a bit weird, where can I help with these ? )

And yes, backports are enabled here.

Yeah, I made a mistake, date format (string formatting, not the settings from gui) can only be set from gsettings, not from GUI (atm). Curious to the output of locale date_fmt though.

Translations for budgie-extras are handled by transifex … so please can you review the current translations and provide updates where necessary. → errr… 404



Link works fine here.

Jacob wants you to run the following from a terminal

locale date_fmt
coeur-noir@asgard:~$ locale date_fmt
%A %-e %B %Y, %H:%M:%S (UTC%z)

Thanks! That is helpful. Need to get back to you on this in the next few days. need to run. I think I see what the issue is, need to fix.

…ok now, I had to ask to be part of the organisation first

I can see you’re very busy : Bug in ShowTime Applet in 19.04 Preview :wink:
There month appears in date, so maybe related to language ?

@Coeur-Noir, no, that’s not related in any way.

Ah ah, suspense… I hope you let us know :wink:

FIxed it in the code. It should be available soon in an update.

Please can you add our test PPA to check that the fix does work correctly:

sudo add-apt-repository ppa:ubuntubudgie-dev/budgie-extras-daily
sudo apt-get update && sudo apt upgrade

You should purge the PPA afterwards to restore back to the current backports version

sudo ppa-purge ppa:ubuntubudgie-dev/budgie-extras-daily

Tadaaaa !

Month is back after adding test PPA, indeed.

And gone away again after ppa-purge…

thx. Will now create a new bug fix release for Disco and upload it. Once done will then update backports with this new fixed version.

Stay tuned. cheers.

Regular update yesterday and month is back :wink:

Yay! Kind of what I expected :slight_smile: