Regional Format for Show Time

I was curios if regional format option could be added to the show time applet ? Instead of Tuesday 1 December an option to change to Tuesday December 1 would be nice.

If you are a bit familiar with dconf / gsettings (use dconf editor), look at the key: /org/ubuntubudgie/plugins/budgie-showtime/dateformat, there you can set an alternative format, according to https://valadoc.org/glib-2.0/GLib.DateTime.format.html

Thanks for the work around. I suspected there was a way to change the format, but was suggesting a way to do this in the applets settings.

To me this doesnt really live in budgie settings - the date format is already complicated enough - so not the sort of thing a ‘standard’ linux user could cope with - adding to settings would involve lots of GUI changes and checks/validations/preview type thing.

The default format actually is the regional format, according to the language & interface settings of the computer.

The default format actually is the regional format, according to the language & interface settings of the computer.

My language and region were selected during installation and not reflected in show time.

To me this doesn’t really live in budgie settings - the date format is already complicated enough - so not the sort of thing a ‘standard’ linux user could cope with - adding to settings would involve lots of GUI changes and checks/validations/preview type thing.

Understand , I remember playing with formats in XFCE . I am familiar with this because on making my own conky syntax.

Anyway,I used the work around in dconf editor. %A %B %d

interesting - what is your current language and region set to?

what is the output of locale -a - need to reproduce and understand what is going on here.

david@d-box:~$ locale
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
david@d-box:~$ 
david@d-box:~$ locale -a
C
C.UTF-8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IL
en_IL.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
POSIX

hmm - I set my environment vars via the terminal and restarted showtime and it displayed as “tuesday december 1” format. So I’m not sure why you are seeing “tuesday 1 december”

It seems to be fine now. displaying Friday, December 3rd.