Dual monitor : correctly set « picture options » for desktop and lock screen background


I know it’s not Budgie’s fault but rather gnome-control-center not giving access to « picture options ».

When using a dual monitor setup, if you like to have a wallpaper that « goes across » the whole surface of both your screen, first you need a picture of the correct size ( if 2 landscape HD monitors side by side, something like 3940×1080 px ).

Set that picture as background as usual.

Then in dconf-editor look for
org.gnome.desktop.background picture-options and here chose « spanned »
org.gnome.desktop.screensaver picture-options and here same chose « spanned » or « scaled ».

It perfectly fits for desktop background, it’s a bit weird for screensaver / lockscreen but less weird to my eyes than the « zoom » option ( which also centers the image, so it’s split and cropped as shown in next post ).

Yeah I post that as a future reminder for myself but may serve anyone.

Another trick → replace ~/.local/share/backgrounds by a symlink to your desired folder containing your own wallpapers → this way they’ll show up in gnome-control-center.

And last one → if you use « display user’s background » in login screen, be sure the whole path to your picture is rwXr-Xr-X ( lightdm user needs to access that picture ).

I’m still looking for being able to « span » the background in lightdm but it seems impossible ?