Extra option in budgie-desktop's LMB

I was trying to get Mate’s caja's desktop work instead of the usual nemo-desktop. However it didn’t work and now I’m stuck with an extra option which leads to an awkwardly empty application.

Anyway to remove that? Also, how do i use caja as desktop manager instead of nemo?
I would be glad for any help.

Hi,

mate-control-center is probably the package you need to remove.

It has caja-common as dependency and caja-common is also a dependency of caja

Did you just install caja or the whole Mate Desktop Environment ? It’s always tricky to install many DE - and even trickier with Mate over any other ±Gnome based DE.

i installed the whole mate desktop because it was so fun (it’s my second favourite after budgie). The fix didn’t work. I also uninstalled the whole mate-desktop :sob:, but it still workn’t…

Any help :0

Did you dedicate an user per desktop environment, or did you launch both budgie and mate with the same user ( therefore same $HOME ) ?

Thou shall never install many DE under 'buntu, that’s deadly sin.

Clean reinstall will be the fastest solution.

Backup your visible documents and media first.

Or if you have time, look for anything mate related in your system + in the hidden elements of your $HOME, remove them, re-install whole budgie DE package then reboot.

And pray the apocalypse knights spared you.

xdg-mime default caja-folder-handler.desktop inode/directory application/x-gnome-saved-search

To check:

xdg-mime query default inode/directory

should then read caja something.

I have done that deadly sin and now … backing things up. There is no trace of MATE other than in icons.

Also, btw mezcalbert, the first just gave a newline and the second gave nemo.desktop

Are you sure ?

dpkg -l | grep mate

…to see installed packages mentioning “mate”

Also

echo ; lsb_release -d; uname -srpi; echo $XDG_CURRENT_DESKTOP under $XDG_SESSION_TYPE amongst :; ls /usr/share/xsessions

It means that nemo is currently handling your files by default.

If you have uninstalled all things MATE, the caja .desktop file has probably been deleted, so it can’t be used by xdg-mime.
If you want caja to do that, you’ll have to reinstall it (beware all the MATE dependencies you have removed will be installed once again) then you might need to look up the exact command but this should be similar to the first one I gave you.

Although I’m not exactly sure what you want now.

Also, can you tell us somehow which control center package is running? As stated by Coeur Noir, this doesn’t seem like the proper control center, and it might be empty because you’ve removed all things MATE.
If you can tell us which one you’re launching, we might be able to either change it or fill it with the proper settings once again.