Ubuntu Budgie 22.04 - Troublesome workplace problems

Hello, I suddenly have a big problem with the workplace. I think it occurred after uninstalling gnome-shell. I uninstalled gnome-shell because there was a huge problem with locking a user and power functions/screen lock. This now works as it should.

Here’s the problem. After logging in, it takes a very long time until the autostart programs are loaded and can be seen at the top of the system tray. For example, when I start Telegram Messenger now, it takes 10-20 seconds for the program to fully launch.

Starting Telegram via the shell shows these error messages:

poi@poiUbuntu:~$ telegram
error: : cannot open
error: : cannot open
error: : cannot open
qt.gui.imageio.jpeg: Corrupt JPEG data: premature end of data segment
qt.gui.imageio.jpeg: Corrupt JPEG data: premature end of data segment
qt.gui.imageio.jpeg: Corrupt JPEG data: premature end of data segment

Some error messages with journalctl -f shows:

Mai 23 17:40:52 poiUbuntu budgie-panel[5927]: instance with invalid (NULL) class pointer
Mai 23 17:40:52 poiUbuntu budgie-panel[5927]: g_signal_handlers_disconnect_matched: assertion ‘G_TYPE_CHECK_INSTANCE (instance)’ failed

Mai 23 17:43:00 poiUbuntu gnome-screensav[6147]: gtk_label_set_markup: assertion ‘GTK_IS_LABEL (label)’ failed
Mai 23 17:43:14 poiUbuntu budgie-panel.desktop[509879]: qt.gui.imageio.jpeg: Corrupt JPEG data: premature end of data segment
Mai 23 17:43:54 poiUbuntu budgie-panel[5927]: Unity.vala:249: LauncherEntry ‘:1.172’ is behaving badly, skipping requests
Mai 23 17:44:00 poiUbuntu gnome-screensav[6147]: invalid unclassed pointer in cast to ‘GtkLabel’
Mai 23 17:43:14 poiUbuntu budgie-panel.desktop[509879]: qt.gui.imageio.jpeg: Corrupt JPEG data: premature end of data segment
Mai 23 17:43:54 poiUbuntu budgie-panel[5927]: Unity.vala:249: LauncherEntry ‘:1.172’ is behaving badly, skipping requests

The bigger problem is that I can’t use any of the icons on the workstation! Double click or move or the “rubber band”. Nothing works. How can I solve this problem? Can anyone help me or give me tips?

Best thanks and greetings!

Budgie doesn’t use the gnome-shell, did you install it and remove it ?

Hello, gnome-shell has always been installed, Budgie did not exist then. At that time I used Unity. The Unity was discontinued I then fell in love with Budgie. Everything worked fine until the upgrade to 22.04…

Greetings!

Hmm - sounds like there could be lots of potential conflict here - may be difficult to pin down :frowning:

Just to check - we strongly recommend using slick-greeter for your login manager. GDM does not play nice with Budgie. Are you using slick-greeter?

Hello, I use Light-DM. GDM3 is completely uninstalled (-force).
Should I switch to Slick Greeter?

I have been using Light-DM for a very long time. Even before version 22.04 everything was okay.

Tx.

light-dm-greeter or slick-greeter are just fine - its just GDM that is the problematic login manager.

Suggest create a new user and login with that. Does things work ok? If it does work ok then its a user account specific issue rather than a system wide issue.

Hello,
this problem also exists with a new user. My Computer (all icons) are frozen and not usable. Also the “rubber band” to select is not present…

Tx!

I’ll be honest with you - it sounds like you have managed to corrupt your installation - something vital has been removed by whatever method you have uninstalled gnome-shell.

It would be quicker simply to backup your home-folder contents and simply do a clean install.

Sounds like you have ( or had ) many desktop environments installed at once on your system.

Please show output of :

echo ; lsb_release -dc; uname -srpi; echo $XDG_CURRENT_DESKTOP under $XDG_SESSION_TYPE amongst ; ls /usr/share/xsessions

and

find ~ ! -user $USER

Hi,

echo ; lsb_release -dc[…]:

Description: Ubuntu 22.04 LTS
Codename: jammy
Linux 5.11.0-43-generic x86_64 x86_64
Budgie:GNOME under x11 amongst
budgie-desktop.desktop lxqt.desktop

and find ~ ! -user $USER

poi@poiUbuntu:~$ find ~ ! -user $USER
poi@poiUbuntu:~$

Tx!

Good news is : no permissions and rights issues in your personal folder.

But.

You have the lxqt desktop environment installed alongside the budgie DE.

Which is weird since you mentioned earlier gnome-shell which is part of Gnome and Ubuntu DE, and neither of Budgie nor LxQt…

If you actually installed many DE or removed/installed pieces of them without caution, it’s a good path for breaking things as ×buntu are not designed for running many DE all at once.

The long road now is to get rid of any bits of DE which are not Budgie related.

The shorter and easier road is : to backup your precious data, and reinstall ONE variant of ×buntu and no other DE beyond.

Your precious data are in $HOME = /home/<your_user_name>
This folder hosts 2 families of data :
visible ones = your medias and documents ( pictures, music, videos, desktop and so on )
hidden ones = names beginning with a . dot which are configs, settings and parameters related to any programs ( including DE ) ever launched by <your_user_name>.

In a fresher UbuntuBudgie installation, you’ll then re-import only the visible data.

From hidden data you might re-import some bits of them but not all !
Only profiles for some programs, depending on your usage, things like .mozilla, .thunderbird, ./config/libreoffice or .config/GIMP

If you’d re-import all the hidden data from your older system into the newer installed one, you’d most likely trigger the same problems again.

2 Likes

It usually works (multiple DEs on Ubuntu), but not by just installing-removing-installing-removing, you have to be very cautious indeed to remove the extra bits that didn’t go away. It can get finicky but with extra care, it should be alright.

Some “sudo apt autoremove --purge” is a start to remove stuff that are useless.

Then indeed as Coeur Noir says, going bit by bit on the DE you had installed to check if some “parasite” packages remain and try to get rid of them (not just lxqt, but its file manager, etc might have dependencies conflicting).

Another suggestion would be to try reinstalling Budgie core packages, and install a couple of icon themes (including reinstalling your current one) and try switching between a few. When you uninstalled Gnome Shell, it might have removed packages that Budgie relies on, superseding Budgie dependencies. Or removed some theming-related files or config files in your /home that would explain that your system fails to find what it’s looking for (hence the loading time and the absence of icons). Which also matches what Coeur Noir suggested. Especially since both Budgie and Gnome are GTK and can use the same things.

Either uninstalling Gnome broke your Budgie packages or lxQT is conflicting. That’s a start.

I don’t believe too much in corrupt systems personally. That’s the beauty of Linux, you can almost always recover a system in a desperate state, even though it might take some time and tinkering. But the trials and errors make you learn crazily to pinpoint future errors.
So don’t give up, try the suggestions given here, explore further, get more suggestions and you will figure this out, we 're not going anywhere.

Hello @Coeur-Noir and @mezcalbert,
I understood all this very well. I will check the problem with the LxQt shortly and try to fix it.
I have already reinstalled the core from Budgie. Has brought nothing.
Just runs a script through, when it is ready I look at your tip by and by!!!
Thanks for now, I need a few days. Then I’ll get back to you and report… :+1: :slightly_smiling_face:

Tx!

Mmmm… I prefer saying careful. It usually does not work on the long run, unless you apply extra care ( at least dedicated user per DE ) but documentation and forum posts are not clear enough about those extra cares.

Each ×buntu variant integrates at its core one DE, which impacts not only user’s side but also system’s side ( session manager, plymouth… )

So while it’s possible to run multiple DE on ×buntu, it’s not at all straightforward and easy.

So, I have uninstalled lxQT completely. No change.

I have reinstalled all packages again after “cleaning up”, I always had positive success in the past:

  • dpkg --get-selections | grep “\binstall” | awk ‘{print $1}’ > /tmp/packages.txt
  • sudo xargs -n1 apt-get --reinstall install -y < /tmp/packages.txt

No success! Still the workstation is frozen. Btw the Budgie docks work, I can work normally!

I have now found out the following about the “Telegram (etc.)” problem. When I install the plugin budgie-sntray-plugin, then the plugin xfce4-sntray-plugin is installed at the same time! What is this! When the plugin is installed and I show it in the top dock then Telegram starts only after about 20 seconds. All other programs that start in the system tray are also delayed. If the plugin is not installed then Telegram (etc.) starts and opens immediately.

I would like to eliminate this problem first. Maybe someone here has a bright idea?

poi@poiUbuntu:~$ wmctrl -m
Name: Mutter(Budgie)
Class: N/A
PID: N/A
Window manager’s “showing the desktop” mode: OFF

Both are status notifiers and would be sharing the same dbus. Basically they are fighting each other.

The xfce plugin shouldnt be running in budgie. It is probably being started via an /etc/xdg/autostart entry. That should really have a desktop session restriction for xfce only.

You dont have xfce installed so that package should be uninstalled.

Hello, no matter what I do it is ALWAYS installed. Via terminal or budgie-welcome.

poi@poiUbuntu:~$ sudo apt install budgie-sntray-plugin
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Die folgenden zusätzlichen Pakete werden installiert:
xfce4-sntray-plugin-common
Die folgenden NEUEN Pakete werden installiert:
budgie-sntray-plugin xfce4-sntray-plugin-common
0 aktualisiert, 2 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 0 B von 96,1 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 904 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] n
Abbruch.

Grrrr… :grimacing:
Let me check your tip. xfce is completely uninstalled/not installed.
Tx!

I’s not the topic and I will try to keep it short. But I basically have 5-6 years installs on both computers with one single user (one might still come back from Unity in 2017), I have Gnome-Budgie on both and I’ve had Liri, pantheon (elementary), wayfire (for kicks), Mate (for Mutiny, the Unity layout of Mate), I also tried to install Lomiri on Manjaro, and probably a couple of others. Of course, I’m an experienced user and I take extra care.

Since the beginning of 2022, I’ve tried Liri and pantheon in addition to the basics I use regularly (Gnome and Budgie).
Guess what? Even then, I haven’t rebooted any of those 2 computers yet in 2022 and they are working great. My laptop’s last boot is on the 28th of december (and I’ve switched between the 4 DEs on that one). And my desktop now has a 9 months uptime (between Gnome and Budgie). I haven’t rebooted since the 20th of August! At this point, it’s so stable I think only a power outage or a hardware upgrade would break my uptime. I suspend both computers every night (this used to be problematic with amdgpu 6 years ago).
So honestly, when you know you’re way around, I think it’s just a myth.

Not the topic indeed : you are an experienced user and you take extra care.
My concern here is : newcomers are wrongly advised about the risks and extra cares needed for running many DE all at once in ×buntu.
And to be honest I can’t believe UBudgie and Mate can work together, under one user. Or maybe our respective tolerance regarding glitches and quirks are very different.
Read : I am interested in your extra cares :wink: I probably lack some of them ! That could be a topic for some how-to maybe ?

I have always used multiple DEs, even with two users. Never had any problems. Mostly it was gnome-shell, xfce4 and most recently Budgie. In the last few years since 20.04 I have exclusively run gnome-shell and Budgie together. All other DEs I tried are uninstalled since 20.04 (–purge).

I do not know what happened now after the move from 21.10 to 22.04LTS! Because some weeks the system ran stable. The only thing I tested was to find the difference of Ububtu-Wayland and xOrg, whether xWayland is finally good for me. Then I found out that Budgie does not run with Wayland…

Something happened here. No clue what.

Tx!

Translated with DeepL Translate: The world's most accurate translator (free version)