Firefox + sound level + 18.04 : level changes every now and then?

Hi,

often listening to music through Firefox on deezer site ( spotify & c° alike ) I’ve noticed sound volume changes every now and then.

It’s not on the first main sound menu I can « see » that but in sounds settings / applications tab or in raven / applet.


This « sound application » cursor goes down without any interaction of mine.
Whereas main sound volume keeps its place.

Any way to « force » such application to keep its sound level ?

Browser specific issue? Does chrome or chromium have the same issue?

Note - you aren’t the first to observe this http://forums.mozillazine.org/viewtopic.php?f=38&t=3024623

EDIT: speculation also in this thread https://www.linuxquestions.org/questions/linux-newbie-8/pulseaudio-changing-volume-randomly-4175610426/

Maybe this ?

Raven
Application controls in the Sound applet will now handle Gvc ChannelMap changes. This is useful since some applications do not provide accurate GvcStream volume immediately when creating their stream, such as Firefox when starting a video. We’ll now ensure we’re updating those values and ensuring applications like Firefox more accurately reflect muted states over Gvc.

Quoted from https://getsol.us/2020/01/25/solus-4-1-released/ § Budgie / Raven

Oh dear, it’s even worse in 19.10.

Any chance it’s not as bad in 20.04 ?

It seems there is a delay / lag / mismatch between sound level in Raven and sound level in settings ?

Please give it a test. If you see any issues then its something you should report on the upstream budgie-desktop issue tracker

I’ll try but for the moment my computer does not boot, I don’t even access bios…

Oops … sounds serious!

To my big surprise and big relief, hard reseting of bios ( button on motherboard ) fixed all !

I’ll try to try as soon as I am sure everything works.

It seems specific to Firefox - sound level does not change through time in chromium-browser.

Chromium as a snap now, with a strange light-grey theme which does not fit with adapta-nokto.