Home Store Blog

Install full Ubuntu Budgie and bootloader on USB drive


#1

Hello. I’m Dondre Johnson. I have a request for the Ubuntu Budgie: I need the team to update the Ubuntu Budgie iso on the download page with an updated installer so that Ubuntu Budgie can successfully be installed on my USB drive.
I don’t like to dualboot systems on my PC’s hard drive, so I decided I’d install systems on a flash drive; a safer way to install and use systems you download. I did so, but the bootloader (GRUB) is installed on my PC instead of my destined USB drive, with the rest of the Ubuntu Budgie system, no matter what, so I can’t use Ubuntu Budgie on any other PC, like other systems like Chromium OS systems. Pop!_OS, on the other hand, does it different; I can bootload Pop!_OS an any PC because it does not depend on a bootloader/GRUB to access the system. But I don’t like Pop!_OS. Ubuntu Budgie has more customization of the Budgie desktop with the Budgie Welcome app. I installed the desktop and the Welcome app on Pop!_OS, but the app wasn’t upported, therefore, I couldn’t customize the desktop any further.
Ubuntu Budgie team, please fix this in your isos so that GRUB won’t be installed on the PC and I can use my USB drive to use Ubuntu Budgie on any PC. Thanks


#2

In the meantime, anyone have a workaround?


#3

You just need to be careful with partitions and use the custom install part of the installer. Be sure to use the correct drive and set the bootloader to be installed on /dev/sdb or whatever block device your flash drive is

Don’t use one of its partitions, or it won’t boot. Then, you can boot by using your BIOS to use the flash drive MBR


#4

Hey. I do use the custom option and got to create 2 partitions in my 16GB flash drive; 40MB for GRUB, and the rest for the system; the 40MB partition was formatted to fat32 and I deleted the other partition and declared it as free space to be formatted to primary ext4 partition. When asked to choose the bootloader partition, there was an option to choose /dev/sdX (the entire drive), /dev/sdX1 (the rest of the drive), or /dev/sdX2 (the 40MB efi partition I chose /dev/sdX2 set it as an efi partition, and GRUB’s still downloaded to my PC partition (I assume is 100MB in partition size), so when I try legacy booting (with the systems I downloaded before, it gave me a UEFI or legacy boot option from the flash drive. This time, only the legacy boot showed up) from the drive, it goes black, and on other computers, it defaults to the PC’s original OS and doesn’t show GRUB at all This is the same thing that happened when I installed Ubuntu Budgie on my drive for the first time using the normal installation method.

So let’s say I now format it to one full fat32 partition from Windows. Is it Ok if you tell me step by step what to do to the drive, so that Ubuntu won’t install GRUB to my PC instead of my drive? Really appreciate it, fossfreedom!


#5

The boot loader has to be on /dev/sdX not a partition. Mind you I have never tried to create a efi booting usb stick … so sorry I can’t help you specifically with that.

This isn’t really a Ubuntu budgie specific issue. All official 18.04 ubuntu flavours use the same installer and the solution will equally apply to all.

Suggest also ask on ubuntuforums.org and/or askubuntu.com


#6

Oh. I’ve tried that already; made the biggest partition an ext4 partition and the smallest partition an efi partition, and selected the bootloader to be on /dev/sdX. I still got the same result.
Pop!_OS, (which is also based on Ubuntu 18.04 (and somewhat Elementary OS)) on the other hand, also installs the bootloader on my PC, but the difference is, when I disable the bootloader on my PC and boot with the flash drive on other computers, it boots its default to Pop!_OS, without showing GRUB at all. So here’s my request; if this problem is unsolvable, you could ask the System76 company to borrow its Pop!_OS installer, so the system will install in the same way Pop!_OS does. Hopefully they say yes.
But thanks for the help anyway, fossfreedom.


#7

Nevermind the System76 installer thing, fossfreedom. I went to askUbuntu, and finally found my one simple solution to my week-old complicated problem: I should’ve booted the USB installer from Legacy mode instead of the default UEFI mode.

(P.S. I always thought someone would say no to this System76 thing anyway.)


#8

Congrats!

That question and all the linked questions is kind of a mess. For future users can you summarise the step you did to boot into legacy mode?


#9

Sure: one user said if you want to install on the flash drive, do not boot the USB installer in UEFI mode. I always installed my systems in UEFI mode; it was like the norm for me. But he said installing the bootloader to /Dev/sdX and not /Dev/sdX’s partition removes the UEFI boot, but leaves the legacy boot empty, which therefore boots me back to Windows on the PC which the system was installed, and does nothing on other PCs. So he said to do restart my PC and boot my USB installer from Legacy mode instead of UEFI mode, so that way when the UEFI mode is removed, the installer has somewhere to put GRUB instead of my PC: the legacy boot of my flash drive.


#10

After a week of looking for answers, his one simple answer could never be found anywhere else. All I ever found was how to force GRUB on your drive, which, either couldn’t find all the resources to finish the installation, or just plain didn’t work. I really thank him for his answer, but with your help, too. To be honest, I doubted going to askUbuntu would help, but I see it’s more active and I got lots answers and suggestions in a matter of 2 hours. Thank you fossfreedom for the suggestion of going to askUbuntu.