Links open in Chromium, not Firefox - how to change?

Links opened from Telegram, Thunderbird etc. all open in Chromium and not Firefox, which would be my preference. I feel like I’ve tried everything and searched several forums including this one. Can someone point me to the right way to configure the default browser to open links with?

Hi and welcome

In budgie control center search for default to display your default applications. Your browser can be chosen from the dropdown

Hi, thanks for the quick reply and the welcoming,

The default web browser is set to Firefox, but links still open in Chromium.

This is 23.04 btw

Have a look at your local mime types to see if various web associations are set to chrome


The mimeapps.list file doesn’t exist in ~/.local/share/applications/

There is ~/.config/mimeapps.list with the following content:

[Removed Associations]

Changing it to:
[Removed Associations]

and then restarting does nothing.

1 Like

File type and app’s associations are stored in :


You may try :

grep http ~/.local/share/applications/mimeinfo.cache

to check which app’ is actually associated to http(s).

In Firefox settings → general or main → start → [ set default ]

Or manually modify mimeinfo.cache file with a text editor ( gedit, nano… )

1 Like

Thanks Coeur-Noir!

Setting Firefox as the default browser from the browser settings worked! I had missed that it was not set as the default browser, as I knew Chromium was also not set as the default browser. I just assumed the default must be Firefox in that case.

I forget, these commands should also help in such a situation :

xdg-settings set default-web-browser firefox.desktop


sudo update-alternatives --install /usr/bin/x-www-browser x-www-browser /usr/bin/firefox 100

when you have a launcher named firefox.desktop in /usr/share/applications
or ~/.local/share/applications
and an element ( file or symbolic link ) named firefox in /usr/bin